Minimum spanning tree --POJ 2421

! ! ! Multiple sets of input is not hung up, I really do not know how they want
Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output

179

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=105;
int n;
int mp[maxn][maxn];
bool vis[maxn];
int d[maxn];

void prim(){
    memset(vis,0,sizeof(vis));
    int ans = 0;
    for(int i=1; i<=n; i++)
        d[i] = mp[1][i];
    vis[1] = 1;
    d[1] = 0;
    for(int i=1; i<=n; i++){
        int end = -1;
        int mmin = INF;
        for(int j=1; j<=n; j++){
            if(!vis[j] && d[j]<mmin){
                mmin = d[j];
                end = j;
            }
        }
        if(mmin == INF)
            printf("%d\n",ans);
        vis[end] = 1;
        ans += mmin;
        for(int j=1; j<=n; j++){
            if(!vis[j] && mp[end][j]<d[j])
                d[j] = mp[end][j];
        }
    }
}
int main(void){
    while(~scanf("%d",&n)){
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&mp[i][j]);
        
        int q,a,b;
        scanf("%d",&q);
        while(q--){
            scanf("%d %d",&a,&b);
            mp[a][b] = mp[b][a] = 0;
        }
        prim();
    }
    return 0;
}

Published 36 original articles · won praise 0 · Views 976

Guess you like

Origin blog.csdn.net/jhckii/article/details/104315018