1047 Student List for Course (25 分) 最后一个测试点总超时 如何解决 我的代码+别人的代码

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题很简单,但是最后一个测试点总超时。

我的代码:

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
char name[40001][5];
vector<int> a[2502];
int cmp(int a,int b)
{
	return strcmp(name[a],name[b])<0;
}
int main()
{
	int n,k,i,j,t,d;
	scanf("%d %d",&n,&k);
	for(i=0;i<n;i++)
	{
		scanf("%s",&name[i]);
		scanf("%d",&t);
		for(j=0;j<t;j++)
		{
			scanf("%d",&d);
			a[d].push_back(i);
		}
	}
	for(i=1;i<=k;i++)
	{
		sort(a[i].begin(),a[i].end(),cmp);
		printf("%d %d\n",i,a[i].size());
		for(j=0;j<a[i].size();j++)
		{
//			cout<<a[i][j]<<endl;
			printf("%s\n",name[a[i][j]]);
		}
	}
	return 0;
}

别人的代码:

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
vector<string>  a[2503];
int main()
{
	int n,k,i,j,t,d;
    string s;
	scanf("%d %d",&n,&k);
	for(i=0;i<n;i++)
	{
		cin>>s;
		scanf("%d",&t);
		for(j=0;j<t;j++)
		{
			scanf("%d",&d);
			a[d].push_back(s);
		}
	}
	
	
	for(i=1;i<=k;i++)
	{
		sort(a[i].begin(),a[i].end());
	}
	for(i=1;i<=k;i++)
	{
		printf("%d %d\n",i,a[i].size());
		for(j=0;j<a[i].size();j++)
		{
			printf("%s\n",a[i][j].c_str());
		}
	}
	return 0;
}

这种思路,我第一次也想到了,但是超时,仔细观察。

最后的输出字符串,用cout就超时。

这句话起了作用。

printf("%s\n",a[i][j].c_str());

// c_str()返回一个客户程序可读不可改的指向字符数组的指针,不需要手动释放或删除这个指针。

扫描二维码关注公众号,回复: 8865384 查看本文章

c_str()函数返回一个指向正规C字符串的指针常量, 内容与本string串相同。

这是为了与c语言兼容,在c语言中没有string类型,故必须通过string类对象的成员函数c_str()把string 对象转换成c中的字符串样式。

注意:一定要使用strcpy()函数 等来操作方法c_str()返回的指针。

//更好的方法是将string数组中的内容复制出来 所以会用到strcpy()这个函数  
    char *c = new char[20];  
    string s = "1234";  
    // c_str()返回一个客户程序可读不可改的指向字符数组的指针,不需要手动释放或删除这个指针。  
    strcpy(c,s.c_str());  
发布了374 篇原创文章 · 获赞 101 · 访问量 21万+

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/103160514