SDUT-3337 计算长方体、四棱锥的表面积和体积(JAVA*)

计算长方体、四棱锥的表面积和体积

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

计算如下立体图形的表面积和体积。

            

                         

从图中观察,可抽取其共同属性到父类Rect中:长度:l  宽度:h  高度:z

在父类Rect中,定义求底面周长的方法length( )和底面积的方法area( )。

 

定义父类Rect的子类立方体类Cubic,计算立方体的表面积和体积。其中表面积area( )重写父类的方法。

定义父类Rect的子类四棱锥类Pyramid,计算四棱锥的表面积和体积。其中表面积area( )重写父类的方法。

输入立体图形的长(l)、宽(h)、高(z)数据,分别输出长方体的表面积、体积、四棱锥的表面积和体积。

Input

 输入多行数值型数据(double);

每行三个数值,分别表示l h z

若输入数据中有非正数,则不表示任何图形,表面积和体积均为0。

Output

 行数与输入相对应,数值为长方体表面积 长方体体积 四棱锥表面积 四棱锥体积(中间有一个空格作为间隔,数值保留两位小数)

Sample Input

1 2 3
0 2 3
-1 2 3
3 4 5

Sample Output

22.00 6.00 11.25 2.00
0.00 0.00 0.00 0.00
0.00 0.00 0.00 0.00
94.00 60.00 49.04 20.00

Hint

 四棱锥体公式:V=1/3Sh,S——底面积 h——高

Source

zhouxq

import java.util.*;
import java.text.*;

class Rect {
	double l, h, z;

	Rect(double a,double b,double c)
	{
		if(a>0&&b>0&&c>0)
			{l=a;h=b;z=c;}
		else
			l=h=z=0;
	}
	double area()
	{
		return l*h;
	}
	double v()
	{
		return l*h;
	}
}

class cubic extends Rect
{
	cubic(double l,double h,double z)
	{
		super(l,h,z);
	}
	double area()
	{
		return 2*super.area()+l*z*2+2*z*h;
	}
	double v()
	{
		return super.area()*z;
	}
}
class pyramid extends Rect
{
	pyramid(double l,double h,double z)
	{
		super(l,h,z);
	}
	double area()
	{
		return super.area()+Math.sqrt(Math.pow(h/2, 2)+Math.pow(z, 2))*l+Math.sqrt(Math.pow(l/2, 2)+Math.pow(z, 2))*h;
	}
	double v()
	{
		return super.area()*z*(1.0/3);
	}
}
public class Main {
	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
		DecimalFormat two = new DecimalFormat("0.00");//控制输出格式
		while (cin.hasNextLine()) {
			double a = cin.nextDouble();
			double b = cin.nextDouble();
			double c = cin.nextDouble();
			cubic x=new cubic(a,b,c);
			pyramid y=new pyramid(a,b,c);
			System.out.println(two.format(x.area())+" "+two.format(x.v())+" "+two.format(y.area())+" "+two.format(y.v()));
		}
		cin.close();
	}
}

猜你喜欢

转载自blog.csdn.net/wzy_2017/article/details/80071479
今日推荐