Dynamic Programming?(暴力)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yuewenyao/article/details/89005534

题目

Dynamic Programming, short for DP, is the favorite of iSea. It is a method for solving complex problems by breaking them down into simpler sub-problems. It is applicable to problems exhibiting the properties of overlapping sub-problems which are only slightly smaller and optimal substructure. 
Ok, here is the problem. Given an array with N integers, find a continuous subsequence whose sum’s absolute value is the smallest. Very typical DP problem, right? 

Input

The first line contains a single integer T, indicating the number of test cases. 
Each test case includes an integer N. Then a line with N integers Ai follows. 

Technical Specification 
1. 1 <= T <= 100 
2. 1 <= N <= 1 000 
3. -100 000 <= Ai <= 100 000 

Output

For each test case, output the case number first, then the smallest absolute value of sum.

Sample Input

2
2
1 -1
4
1 2 1 -2

Sample Output

Case 1: 0
Case 2: 1

题意:给你n个数,有正有负,求连续最小绝对值,由于数值范围较小,我们可以直接暴力操作。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
  int t , n , sum , mi , a[1005];
  while(cin >> t)
  {
    for(int k = 1 ; k <= t ; k ++)
    {
      memset(a,0,sizeof(a));
      cin >> n;
      for(int i = 1 ; i <= n ; i ++)
          cin >> a[i];
      mi = abs(a[1]);
      for(int i = 1 ; i <= n ; i ++)
      {
        sum = 0 ;
        for(int j = i ; j <= n ; j ++)
        {
            sum += a[j];
            mi = min(abs(sum),mi);
        }
      }
      printf("Case %d: %d\n",k,mi);
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/yuewenyao/article/details/89005534