Dynamic Programming?

Dynamic Programming, short for DP, is the favorite of iSea. It is a method for solving complex problems by breaking them down into simpler sub-problems. It is applicable to problems exhibiting the properties of overlapping sub-problems which are only slightly smaller and optimal substructure. 
Ok, here is the problem. Given an array with N integers, find a continuous subsequence whose sum’s absolute value is the smallest. Very typical DP problem, right? 

Input

The first line contains a single integer T, indicating the number of test cases. 
Each test case includes an integer N. Then a line with N integers Ai follows. 

Technical Specification 
1. 1 <= T <= 100 
2. 1 <= N <= 1 000 
3. -100 000 <= Ai <= 100 000 

Output

For each test case, output the case number first, then the smallest absolute value of sum.

Sample Input

2
2
1 -1
4
1 2 1 -2

Sample Output

Case 1: 0
Case 2: 1

题意:给你一段数组求你的连续的绝对值最小的序列并输出

思路:暴力枚举每一段

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath> 
#define inf 0x3f3f3f3f3f3f
using namespace std;
long long a[1000009],dp[1000009];
int main()
{
	long long t,n,min1;
	scanf("%lld",&t);
	long long g=1;
	while(t--)
	{
		min1 = inf;
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		scanf("%lld",&n);
		for(long long i=1;i<=n;++i)
		{
			scanf("%lld",&a[i]);
			a[i] = a[i-1]+a[i];//存前几项和
		}
		for(long long i=1;i<=n;++i)
		{
			dp[i] = inf;
			for(long long j=0;j<i;++j)
			{
				dp[i] = min(dp[i],abs(a[i]-a[j]));//枚举每一段
			}
			min1 = min(dp[i],min1);
		}
		printf("Case %lld: %lld\n",g,min1);//输出
		g++;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43568078/article/details/89016979