Enumeration?

Problem Description

In mathematics and theoretical computer science, the broadest and most abstract definition of an enumeration of a set is an exact listing of all of its elements (perhaps with repetition). 
If we are blocked by a tricky but small issue, a good way is stop bothering and calculating, and just enumerates all the possible result. Here is such a case. iSea is fond of coins recently, now he gets three coins, after throwing all of them again and again, he finds some of those coins are not side equivalent, because the times it faces up and faces down are not equal. Here we assume iSea has thrown the coin enough times that we can treat this as random happened and use the number to count probability. 
iSea is a typical Libra, placing in equilibrium at the first position always. He want to distribute the probability to the three coins, and each time he chooses a coin from them with this probability, throws the coin, records facing up or down, and this time after summing up all the times whether the coins face up or down the ideal probable number should be perfectly equal. Again, is this possible? Remember the probability for each coin can’t be zero.

Input

The first line contains a single integer T, indicating the number of test cases.
Each test case includes Six integers Up1, Down1, Up2, Down2, Up3, Down3, indicating the times facing up and down of the first, second and third coin, respectively.

Technical Specification
1. 1 <= T <= 10 000
2. 1 000 000 <= Up, Down <= 2 000 000

Output

For each test case, output the case number first, if possible, output "Yes", otherwise output "No" (without quote).

Sample Input

 

2 1000000 1000001 1000000 1000002 1000000 1000003 1000000 1000001 1000000 1000002 2000000 1000003

Sample Output

 

Case 1: No Case 2: Yes

Author

iSea@WHU

Source

首届华中区程序设计邀请赛暨第十届武汉大学程序设计大赛

Recommend

lcy

题意:给你硬币的向上向下次数,让你判断是否可能存在向上的概率等于向下的概率

思路:3个硬币中只要一个向上概率大一个向下概率大或向下的概率永远等于向上概率输出yes

其他no皆可

代码:

#include<iostream>
using namespace std;
int main()
{
	int n;int g = 1;
	scanf("%d",&n);
	int up1,down1,up2,down2,up3,down3;
	while(n--)
	{
		scanf("%d%d%d%d%d%d",&up1,&down1,&up2,&down2,&up3,&down3);
		if(up1 < down1 && up2 > down2)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up1 < down1 && up3 > down3)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up1 > down1 && up2 < down2)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up1 > down1 && up3 < down3)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up2 < down2 && up3 >down3)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up2 < down2 && up1 > down1)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up2 > down2 && up3 < down3)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up2 > down2 && up1 < down1)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up3 > down3 && up1 < down1)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up3 > down3 && up2 < down2)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up3 < down3 && up1 > down1)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up3 < down3 && up2 > down2)
		{
			printf("Case %d: Yes\n",g);
		}
		else if(up1 == down1 && up2 == down2 && up3 == down3){
			printf("Case %d: Yes\n",g);
		}
		else{
			printf("Case %d: No\n",g);
		}
		g++;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43568078/article/details/89017180