hdu 1045

http://acm.hdu.edu.cn/showproblem.php?pid=1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16485    Accepted Submission(s): 10033


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 
Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 
Sample Output
5 1 5 2 4
 
Source
 
Recommend
We have carefully selected several similar problems for you:   1016  1051  1050  1175  1241 
 
题解:
         用深度优先搜索,按顺序先找一个点,标记这个点的位置,再找下一个符合要求的点,直到找不到为止;
   
1. 
     用于判断是否可以放:
    可以放就找下一个;
                flag=0;
                //space!!; 
                for(int i=0;i<4;i++)
                {
                    int tw=w, tk=k;// 重点!!!!!!!  每次判断是从k,w对应的点开始; 如果把( int tw=w, tk=k;) 放在space!!处,
                                    //    会导致 第二个方向搜索的起点是第一个方向搜索的终点;      
                    while(1)
                    {
                        tw=tw+next[i][1]; tk=tk+next[i][0];
                        if(book[tk][tw]==0)//遇到边界 
                        {
                            break;
                        }
                        else if(book[tk][tw]==2)//遇到墙 
                        {
                            break;
                        }
                        else if(book[tk][tw]==3)//遇到碉堡 
                        {
                            flag=1;
                            break;
                        }
                        //tw=tw+next[i][1]; tk=tk+next[i][0];
                    }
                }
                if(flag==0)//
                {
                    book[k][w]=3;
                    dfs(num+1);
                    book[k][w]=1;
                }
 
#include<cstdio>
#include<cstring>

using namespace std;

int n;
char str[6];
int book[6][6];
int max;
int flag;
int next[4][2]={{1,0},{0,1},{-1,0},{0,-1}};

void dfs(int num)//深度优先搜索 ,以放的数量为参数递归,一直递归到不能放为止;
{
    //printf("%d\n",num);
    if(max<num)
    {
        max=num;//每次递归更新数据,从而得到最大值; 
    }
    for(int k=1;k<=n;k++)
    {
        for(int w=1;w<=n;w++)
        {
            if(book[k][w]==1)//表示为空; 
            {
                flag=0;
                //space!!; 
                for(int i=0;i<4;i++)
                {
                    int tw=w, tk=k;// 重点!!!!!!!  每次判断是从k,w对应的点开始; 如果把( int tw=w, tk=k;) 放在space!!处,
                                    //    会导致 第二个方向搜索的起点是第一个方向搜索的终点;      
                    while(1)
                    {
                        tw=tw+next[i][1]; tk=tk+next[i][0];
                        if(book[tk][tw]==0)//遇到边界 
                        {
                            break;
                        }
                        else if(book[tk][tw]==2)//遇到墙 
                        {
                            break;
                        }
                        else if(book[tk][tw]==3)//遇到碉堡 
                        {
                            flag=1;
                            break;
                        }
                        //tw=tw+next[i][1]; tk=tk+next[i][0];
                    }
                }
                if(flag==0)//
                {
                    book[k][w]=3;
                    dfs(num+1);
                    book[k][w]=1;
                }
            }
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            return 0;
        }
        memset(book,0,sizeof(book));//初始化,使没有赋值的都为零; 
        for(int i=1;i<=n;i++)
        {
            getchar();
            scanf("%s",str);
            for(int j=0;j<n;j++)
            {
                if(str[j]=='.')
                {
                    book[i][j+1]=1;//记录空的地方;
                }
                else if(str[j]=='X')
                {
                    book[i][j+1]=2;//记录有墙的地方;
                }
            }//book[i][j]=3记录碉堡;book[i][j]=0表示边界;
        }
        max=0;
        dfs(0);
        printf("%d\n",max);
    } 
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/qqshiacm/p/10544504.html