G - Can you answer these queries?

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6

#include <algorithm>
#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
#define fore(i, a, b) for (int i = a; i <= b; i++)
#define l(x) Tree[x].l
#define r(x) Tree[x].r
#define sum(x) Tree[x].sum
#define add(x) Tree[x].add
typedef long long ll;
typedef long double ld;
const int MAXN = 100005;

struct segmentTree {
    int l, r;
    long long sum;
    int add;
} Tree[MAXN * 4];
int a[MAXN], n, m;

void build(int p, int l, int r) {
    add(p)=0;
    l(p) = l, r(p) = r;
    if (l == r) {
        scanf("%lld",&sum(p));
        return;
    }
    int mid = (l + r) / 2;
    build(p * 2, l, mid);
    build(p * 2 + 1, mid + 1, r);
    sum(p) = sum(p * 2) + sum(p * 2 + 1);
}


void change(int p, int l,int r) {
    if(add(p)==1) return;
    if (l(p)==r(p)) {sum(p)=sqrt(sum(p));if(sum(p)==1) add(p)=1;return;}
    int mid = (l(p) + r(p)) / 2;
    if (l <= mid) change(p * 2, l,r);
    if(r>mid) change(p * 2 + 1, l,r);
    sum(p) = sum(p * 2) + sum(p * 2 + 1);
    if (add(p * 2) == 1 && add(p * 2 + 1) == 1) add(p) = 1;
}

long long ask(int p, int l, int r) {
    if (l <= l(p) && r >= r(p)) return sum(p);
    int mid = (l(p) + r(p)) / 2;
    long long val = 0;
    if (l <= mid) val += ask(p * 2, l, r);
    if (r > mid) val += ask(p * 2 + 1, l, r);
    return val;
}

int main() {
    int casei=0;
    while(cin>>n){
        printf("Case #%d:\n", ++casei);
        //fore(i, 1, n) scanf("%d", &a[i]);
        build(1, 1, n);
        cin >> m;
        int d, x, y;
        while (m--) {
            scanf("%d%d%d", &d, &x, &y);
            if(x>y) swap(x,y);
            if (d)
                printf("%lld\n", ask(1, x, y));
            else {
                change(1,x,y);
            }
        }
        puts("");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/rign/p/10486180.html