HDU 2141 Can You Find It?(二分)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 43435    Accepted Submission(s): 10508


 

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

 

Sample Input

 

3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10

 

Sample Output

 

Case 1: NO YES NO

题意:给A,B,C三个序列,分别从这三个序列中找三个数,若存在三个数之和等于X,则输出”YES”,否则输出”NO”

思路:三重循环的搜索肯定是不能用的。我的解法是将a+b的值存到ab数组中,将该数组排序。再用二分搜索判断x-c是否存在于该数组中,若存在,则证明存在x=a+b+c,输出’YES’即可。若对于所有c,都不存在x-c属于该数组,则证明不存在x=a+b+c,输出’NO’即可。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int sum[250010],a[505],b[505],c[505];
int div(int begin,int end,int ans) //二分查找函数
{
	int left=begin,right=end;
	while(left<=right) 
	{
		int mid=left+right>>1;
		if(sum[mid]==ans) return 1;  //找到
		if(sum[mid]>ans) right=mid-1;
		else if(sum[mid]<ans) left=mid+1;
	}
	return 0;
}
int main(){
	
	int k=1;
	int i,j;
	int l,n,m;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF)
	{
		printf("Case %d:\n",k);
		for(i=1;i<=l;i++) scanf("%d",&a[i]);
		for(i=1;i<=n;i++) scanf("%d",&b[i]);
		for(i=1;i<=m;i++) scanf("%d",&c[i]);
		int cnt=1;
		for(i=1;i<=l;i++)
		for(j=1;j<=n;j++)
		sum[cnt++] = a[i]+b[j];
		sort(sum+1,sum+cnt);
		int t;
		scanf("%d",&t);
		while(t--)
		{
			int x,ans;
			int flag=0;
			scanf("%d",&x);
			for(i=1;i<=m;i++)
			{
				ans=x-c[i];
				if(div(1,cnt-1,ans)) 
				{
					flag=1;
					break;
				}
			}
			if(flag) cout<<"YES"<<endl;
			else cout<<"NO"<<endl;
		}
		k++; 
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/zvenWang/article/details/83216309