1059 C语言竞赛 (setw(), setfill())

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LightInDarkness/article/details/83051820

C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

  • 0、冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
  • 1、排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
  • 2、其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数 N(≤10​4​​),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。

输出格式:

对每个要查询的 ID,在一行中输出 ID: 奖品,其中奖品或者是 Mystery Award(神秘大奖)、或者是 Minion(小黄人)、或者是 Chocolate(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked(不能多吃多占)。

输入样例:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

输出样例:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

分析:

       求素数这里用了筛选法,开辟一个stu数组,存储排名,为0则没有该ID,如被检查过,改为一个非ID的值。也是很简单的一个题,就是通过率略低。

#include<iostream>
#include<iomanip>

using namespace std;

int stu[10000] = {0}, prime[10001];

//筛选素数
void SelectPrime(){
	for(int i = 0; i < 10001; i++) prime[i] = 1;
	for(int i = 2; i * i <= 10000; i++){
		if(prime[i] == 1){
			int j = i * i;
			while(j <= 10000){
				prime[j] = 0;
				j += i;
			}
		}
	}
}

int main(){
	int N, temp;
	SelectPrime();
	cin >> N;
	//Winner is marked as 1, and the others are marked as 2.
	for(int i = 0; i < N; i++){
		cin >> temp;
		stu[temp] = i + 1;
	}
	//Check    3 means this ID has been checked.
	cin >> N;
	for(int i = 0; i < N; i++){
		cin >> temp;
		if(stu[temp] == 1){
			cout << setw(4) << setfill('0') << temp << ": Mystery Award" << endl;
			stu[temp] = 10001;
		}else if(stu[temp] >= 2 && stu[temp] <= 10000){
			if(prime[stu[temp]] == 1){
				cout << setw(4) << setfill('0') << temp << ": Minion" << endl;
				stu[temp] = 10001;
			}else{
				cout << setw(4) << setfill('0') << temp << ": Chocolate" << endl;
				stu[temp] = 10001;
			}
		}else if(stu[temp] == 10001){
			cout << setw(4) << setfill('0') << temp << ": Checked" << endl;
		}else if(stu[temp] == 0){
			cout << setw(4) << setfill('0') << temp << ": Are you kidding?" << endl;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/LightInDarkness/article/details/83051820