hdu-1285 拓扑排序java

确定比赛名次

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
 
   
4 3 1 2 2 3 4 3
 

Sample Output
 
   
1 2 4 3
package 拓扑排序;

import java.util.*;

public class Main {

	static List<Integer> list = new ArrayList<>();
	static int teamnum=0;
	static Scanner sc = new Scanner(System.in);
	static int[][] graph;
	static int[] enter;
	static int num;
	public static void main(String[] args) {
		while (sc.hasNext()) {
			teamnum=sc.nextInt();
			num = sc.nextInt();
			init();
			TopoSort();
			for (int i = 0; i < list.size(); i++) {
				if (i == list.size() - 1)
					System.out.print(list.get(i));
				else
					System.out.print(list.get(i) + " ");
			}
			System.out.println();
			list.clear();
		}
	}
	public static void init() {
		graph = new int[teamnum + 1][teamnum + 1];
		enter = new int[teamnum + 1];
		for (int i = 0; i < num; i++) {
			int from = sc.nextInt();
			int to = sc.nextInt();
			if (graph[from][to] == 0) {
				graph[from][to] = 1;
				enter[to]++;
			}
		}
	}
	public static void TopoSort() {
		for (int i = 1; i <= teamnum; i++) {
			int k = 1;
			while (enter[k] != 0)
				k++;
			list.add(k);
			enter[k] = -1;
			for (int j = 1; j <= teamnum; j++) {
				if (graph[k][j] == 1) {
					enter[j]--;
				}
			}
		}
	}

}

猜你喜欢

转载自blog.csdn.net/KingYMxe/article/details/78961838
今日推荐