区间更新区间求和板子 *(线段树lazy)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题意:Q查询区间和,C区间a到b全加上c。

lazy模板

#include<stdio.h>
using namespace std;
#define ll long long
#define N 100010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
struct nomd
{
	int l,r;
	int mid(){
		return (l+r)>>1;
	}
}tree[N<<2];
ll add[N<<2],sum[N<<2];
void up(int rt)//跟新父亲值 建树时用一次  跟新时用一次
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void down(int rt,int m)//lazy标记 m 是tree(r-l)+1.区间数的个数 跟新查询各用一次
{
	if(add[rt])//lazy标记是他没有将下面儿子全部标记,而是查询到了在往下继续标记减少时间 
	{
		add[rt<<1]+=add[rt];
		add[rt<<1|1]+=add[rt];
		sum[rt<<1]+=add[rt]*(m-(m>>1));
		sum[rt<<1|1]+=add[rt]*(m>>1);
		add[rt]=0;
	}
}
void build(int l,int r,int rt)//建树 
{
	tree[rt].l=l;tree[rt].r=r;
	add[rt]=0;
	if(l==r)//在这里输入确实挺涨姿势的.... 
	{
		scanf("%lld",&sum[rt]);
		return ;
	}
	int m=tree[rt].mid();
	build(lson);//宏定义了  二分思想 
	build(rson);
	up(rt);
}
void update(int c,int l,int r,int rt)
{
	if(tree[rt].l==l&&tree[rt].r==r)//跟新和查询过程差不多 正好包含
	{
		add[rt]+=c;
		sum[rt]+=(ll)c*(r-l+1);
		return;
	}
	if(tree[rt].l==tree[rt].r) return;//走到最后了
	down(rt,tree[rt].r-tree[rt].l+1);//更新一下add值
	int m=tree[rt].mid();
	if(r<=m) update(c,l,r,rt<<1);//全在左边
	else if(l>m) update(c,l,r,rt<<1|1);//全在右边
	else//两边都有
	{
		update(c,l,m,rt<<1);
		update(c,m+1,r,rt<<1|1);
	}
	up(rt);
}
ll query(int l,int r,int rt)
{
	if(tree[rt].l==l&&tree[rt].r==r)//
	{
		return sum[rt];
	}
	down(rt,tree[rt].r-tree[rt].l+1);//查询到了就要读取add里的值
	int m=tree[rt].mid();
	ll res=0;
	if(r<=m) res+=query(l,r,rt<<1);//
	else if(l>m) res+=query(l,r,rt<<1|1);//
	else//
	{
		res+=query(l,m,rt<<1)+query(m+1,r,rt<<1|1);
	}
	return res;
}
int main()
{
	int n,m;
	while(~scanf("%d %d",&n,&m))
	{
		build(1,n,1);
		for(int i=0;i<m;i++)
		{
			char w[10];
			scanf("%s",w);
			if(w[0]=='Q')
			{
				int e,ee;
				scanf("%d %d",&e,&ee);
				printf("%lld\n",query(e,ee,1));
			}
			else
			{
				int e,ee,eee;
				scanf("%d %d %d",&e,&ee,&eee);
				update(eee,e,ee,1);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/liuliu2333/article/details/81943830
今日推荐