在n分钟内跑完路程,刚开始跑步他的疲劳度是0,每跑步一分钟疲劳度就增加1,疲劳度不能超过上限m,达到m就必须休息 ,

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

首先设dp[i][j]表示第i分钟疲劳度是j的时候获得的最远距离

dp[i][j]=dp[i-1][j-1]+d[i],这是选择在第i分钟跑步的状态

dp[i][0]=dp[i-1][0],第i分钟仍然在休息,来自于第i-1分钟休息,

若一直休息最大

dp[i][0]=max(dp[i][0],dp[i-k][k])  ,(k<=m;i-k>0)

#include<iostream>
using namespace std;
int dp[20000][600];
int d[20000];
int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        cin>>d[i];
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            dp[i][j]=dp[i-1][j-1]+d[i];
            dp[i][0]=dp[i-1][0];
        }
        for(int k=0;k<=m;k++)
        {
            if(i-k>0)
            {
                dp[i][0]=max(dp[i][0],dp[i-k][k]);
            }
        }
    }
    cout<<dp[n][0];
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/82291196
今日推荐