Can you find it?

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 37626    Accepted Submission(s): 9190


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
 
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
 
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 
PS:将两个数组两两相加,再与另一数组相加,其中,与另一数组的计算过程中,用二分不断缩小区间,达到减小时间复杂度的目的。、

代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<map>
typedef long long ll;
using namespace std;
const int N=1e6+10;
int main()
{
    int l,n,m,kk=1;
    int a[550],b[550],c[550],d[260000];
    while(cin>>l>>n>>m)
    {
        int k=0;
        for(int i=0; i<l; i++)
            cin>>a[i];
        for(int i=0; i<n; i++)
            cin>>b[i];
        for(int i=0; i<m; i++)
            cin>>c[i];
        for(int i=0; i<l; i++)
            for(int j=0; j<n; j++)
                d[k++]=a[i]+b[j];
        sort(d,d+k);
        int s,x;
        cin>>s;
        cout<<"Case "<<kk++<<":"<<endl;
        while(s--)
        {
        int o=0;
            cin>>x;
            for(int i=0; i<m; i++)
            {
                if(binary_search(d,d+k,x-c[i]))
                {
                    o=1;
                    break;
                }
            }
            if(o)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40510246/article/details/79857774