线性dp

Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10598   Accepted: 3787

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible
地址:http://poj.org/problem?id=1745
DP 的含义:dp[i][j]代表到第i个数,余数为多少。
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define FOR(a,b) for(int i=a;i<b;i++)
#define FR(a,b) for(int j=a;j<b;j++)
#define INF 0x3f3f3f3f
#define MAX 10005
int a[MAX];
bool dp[MAX][105];
int main()
{
    int n,k;
    while(~scanf("%d %d",&n,&k))
    {
       memset(dp,false,sizeof(dp));
       FOR(0,n)
       {
           scanf("%d",&a[i]);
           a[i]=fabs(a[i]);
           a[i]=a[i]%k;//先对每个数对k取余
       }
       dp[0][a[0]]=true;
       FOR(1,n)
       {

           FR(0,k)
           {
               if(dp[i-1][j])
               {
                   dp[i][(j+a[i])%k]=true;
                   dp[i][(k+j-a[i])%k]=true;//记住这里的j-a[i],如果只是这么写会出现负数,加个K就行了
               }
           }
       }
       if(dp[n-1][0])
        printf("Divisible\n");
       else printf("Not divisible\n");
    }
}

  

猜你喜欢

转载自www.cnblogs.com/zhgyki/p/9150099.html
今日推荐