葡萄酒贸易

Wine trading in Gergovia
As you may know from the comic “Asterix and the Chieftain’s Shield”,Gergovia consists of one street, and every inhabitant of the city is awine salesman. You wonder how this economy works?Simple enough: everyone buys wine from otherinhabitants of the city. Every day each inhabitant decides how muchwine he wants to buy or sell. Interestingly, demand and supply isalways the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one houseto another results in work. Since all wines are equally good, theinhabitants of Gergovia don’t care which persons they are doing tradewith, they are only interested in selling or buying a specific amountof wine. They are clever enough to figure out a way of tradingso that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading duringone day in Gergovia. For simplicity we will assume thatthe houses are built along a straight line with equal distance betweenadjacent houses. Transporting one bottle of wine from one house to anadjacent house results in one unit of work.
Input Specification

The input consists of several test cases.Each test case starts with the number of inhabitants n (2 ≤ n≤ 100000).The following line contains n integers ai (-1000 ≤ ai≤ 1000).If ai ≥ 0, it means that the inhabitant living in the ithhouse wants to buy ai bottles of wine, otherwise if ai< 0, he wants to sell -ai bottles of wine.You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.
Output Specification
For each test case print the minimum amount of work units needed sothat every inhabitant has his demand fulfilled. You may assume that this numberfits into a signed 64-bit integer (in C/C++ you can use the data type “long long”, in JAVA the data type “long”).
Sample Input

5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

Sample Output

9
9000

中文翻译
题意: 给出n个人, 每个人有一个数字, 正数表示要买酒, 负数表示要卖酒, 他们的绝对值就是他们要买或者要卖的数量, 卖酒的人需要运费的, 费用和他们之间的距离有关, 相邻的距离为1, 然后费用就是要卖的数量乘以1, 隔一个位置的距离就为2了, 运费就是2…然后求运费最少的情况

思路:
事实上我是看着别人的题解做的, 却发现很简单, 因为可以这样想, 第1个人要卖酒给第3个人, 其实就是把酒先全卖给第2个人, 然后第二个人再卖给第3个人, 运费是一样的, 所以这样就容易想到贪心策略, 卖家都优先卖给最近的人, 而且是全部都卖给他…

#include<stdio.h>
#include<stdlib.h>
 
int main() {
    int n;
    while(scanf("%d", &n) != EOF && n) {
        int tmp;
        int num = 0;
        long long count = 0;
        while(n--) {
            scanf("%d", &tmp);
            num += tmp;
            count += abs(num);
        }
        printf("%lld\n", count);
    }
    return 0;
}
temp num count
5 5 5
-4 1 6
1 2 8
-3 -1 9
1 0

num为正表示需要从下一个邻居运来多少,num小于0表示需要从,给下一个邻居运去多少,num为0说明到此已经达到平衡。

原文链接:UVA 11054 (13.11.10)

猜你喜欢

转载自blog.csdn.net/liuweiyuxiang/article/details/89320391