PTA Grade 1083 List Grades (25point (s))

First of all, God first posted Liu's blog

https://www.liuchuo.net/ This is the address

Blog want a good brush PTA, strongly recommended willow God, and algorithms notes

Original title

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100    

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112   

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95  

Sample Output 2:

NONE

Subject to the effect

N is to give students grades, and student achievement in a given interval,

Information required output in the student section inside, not on the output NONE

code show as below

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct student {
    char name[11], id[11];
    int grade;
};
bool cmp(student a, student b) {
    return a.grade > b.grade;
}
int main(void) {
    int N;
    int flag = false;
    scanf("%d", &N);
    vector<student> data(N);
    for (int i = 0; i < N; i++) {
        scanf("%s%s%d", data[i].name, data[i].id, &data[i].grade);
    }
    int grade1, grade2;
    scanf("%d%d", &grade1, &grade2);
    if (grade1 > grade2) {
        int t = grade1;
        grade1 = grade2;
        grade2 = grade1;
    }
    sort(data.begin(), data.end(), cmp);
    for (int i = 0; i < N; i++) {
        if (data[i].grade >= grade1 && data[i].grade <= grade2) {
            printf("%s %s\n", data[i].name, data[i].id);
            flag = true;
        }
    }
    if (!flag) printf("NONE");
    return 0;
}

Guess you like

Origin www.cnblogs.com/a-small-Trainee/p/12455797.html