1044 Shopping in Mars (25 point (s)) - C language PAT Grade

Disclaimer: This article is a blogger original article, follow the CC 4.0 BY-SA copyright agreement, reproduced, please attach the original source link and this statement.
This link: https://blog.csdn.net/huaxuewan/article/details/102408826

1044 Shopping in Mars (25 point(s))

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤ 105), the total number of diamonds on the chain, and M (≤ 108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ⋯ DN (Di ≤ 103 for all i=1, ⋯, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.
If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj > M with (Di + … + Dj − M) minimized. Again all the solutions must be printed in increasing order of i.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

Subject to the effect:

A sequence of N input elements, and the requirements for a continuous sequence exactly equal to the desired M, can not be found if the sequence is exactly equal, to find the minimum cost of the sequence (sequence value must be greater than or equal to M);

The output of all possible outcomes, the index before and after each sequence;

Design ideas:
  • A maintenance window, traverse the window from the beginning to the end, and the cost of maintaining a minimum desired value max
    • if (sum <M), the right side of the window to the right
    • else if (sum> = M), the left window to the right
      • if (sum <max), i.e., the minimum value necessary to change the maintenance cost, need to re-record the results at this time
      • if (sum == M), in line with expectations of the current minimum price, record the results
  • Right of the original sequence can be added to a sentinel value of 0, because the window reaches the end of the sequence, still need to be moved is determined
    • 9, for example, a value of M, a sequence of three elements, plus a sentinel 0
    • 1, 3, 9, 0; after 9 reaches its end, the need continues to move left Analyzing
    • 1, 3, 5, 0; after 5 reaches its end, the right judgment can still enter the loop
Compiler: C (gcc)
#include <stdio.h>
#include <limits.h>

int main(void)
{
        int n, m, d[100001] = {0};
        int p[100000] = {0}, q[100000] = {0}, count = 0, max = INT_MAX;
        int sum = 0;
        int i, j;

        scanf("%d %d", &n, &m);
        for (i = 0; i < n; i++) {
                scanf("%d", &d[i]);
        }

        i = 0; j = 0;
        while (i < n && j <= n) {
                if (sum < m) {
                        sum += d[j];
                        j++;
                } else {
                        if (sum < max) {
                                max = sum;
                                count = 0;
                                p[count] = i + 1;
                                q[count] = j;
                                count++;
                        } else if (sum == max) {
                                p[count] = i + 1;
                                q[count] = j;
                                count++;
                        }
                        sum -= d[i];
                        i++;
                }
        }

        for (i = 0; i < count; i++) {
                printf("%d-%d\n", p[i], q[i]);
        }
        return 0;
}

Guess you like

Origin blog.csdn.net/huaxuewan/article/details/102408826