PAT Grade -1055-The World's Richest (+ sorting out issues)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105 ) - the total number of people, and K (≤103 ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106 ,10​6]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input :
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output :
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

  • This problem doing it quite well, but according to conventional thinking would write timeout , reasons as follows:
    The total number has N (5 th power of ≤10), but each time only need to check before M (≤100) bit rich person, so we canSort inert, Namely: for people of the same age, just take the top 100 most rich and abandon the rest of the time, which can greatly reduce the complexity of the program.
for(int i = 0; i < n; i++){
	scanf("%s %d %d", per[i].name,&per[i].age, &per[i].worths);
}
sort(per.begin(),per.end(),cmp);
for(int i = 0; i < n; i++){
	if(flag[per[i].age] < 100){
		flag[per[i].age]++;
		per2.push_back(per[i]);
	}
}
  • Great Note: The order for two or more cycles can not be reversed! Because the first with a sort Sort after - - - - - -Such will be able to ensure that the wealth value worths are ranked in descending order ofIn order to then find people of the same age of the top 100 most rich people added to the vessel per2 in!

code show as below

#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;
struct person{
	char name[10];
	int age,worths;
};
int cmp(person a,person b){
	if(a.worths != b.worths){
		return a.worths > b.worths;
	}else if(a.age != b.age){
		return a.age < b.age;
	}
	return (strcmp(a.name, b.name) < 0);
}
int main()
{
	int n,k;int flag[205] = {0};
	scanf("%d %d", &n, &k);
	vector<person> per(n);vector<person> per2;
	vector<person> ans;
	for(int i = 0; i < n; i++){
		scanf("%s %d %d", per[i].name,&per[i].age, &per[i].worths);
	}
	sort(per.begin(),per.end(),cmp);
	for(int i = 0; i < n; i++){
		if(flag[per[i].age] < 100){
			flag[per[i].age]++;
			per2.push_back(per[i]);
		}
	}
	for(int i = 1; i <= k; i++){
		ans.clear();
		int x,aMin,aMax;
		scanf("%d %d %d", &x, &aMin, &aMax);
		for(int j = 0; j < per2.size(); j++){
			if(per2[j].age>=aMin && per2[j].age<=aMax && ans.size()<x)
				ans.push_back(per2[j]);
		}
		printf("Case #%d:\n", i);
		if(ans.size() == 0){
			printf("None\n");
		} 
		for(int j = 0; j < ans.size(); j++){
			printf("%s %d %d\n", ans[j].name, ans[j].age, ans[j].worths);
		}
	}
	return 0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

Guess you like

Origin blog.csdn.net/qq_42437577/article/details/104133667