[Explanations] - hdu Switch Game [] to find the law

Switch Game

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1
5

Sample Output

1
0


        
  

Consider the second test case:

The initial condition	   : 0 0 0 0 0
After the first operation  : 1 1 1 1 1
After the second operation : 1 0 1 0 1
After the third operation  : 1 0 0 0 1
After the fourth operation : 1 0 0 1 1
After the fifth operation  : 1 0 0 1 0

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

Hint

hint
        
 

AC Code

#include<stdio.h>
#include<string.h>
int main(void)
{
    int n,arr[100001],i;
    memset(arr,0,sizeof(arr));
    for(i = 1; i * i <= 100000; i ++)
    arr[i * i] = 1;
    while(scanf("%d",&n) != EOF)
    {
        if(n<0||n>100000)
        break;
        printf("%d\n",arr[n]);
    }
    return 0;
}

Thinking

N has a start lamp, and all the off state, are referred to as 0 is The initial condition: 0 0 0 0 0 ...

After then i operating these lamps is whether i is divisible, change state, as it will be 0 to 1 or 1 to 0

As a reminder in the

After the first operation : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation : 1 0 0 1 0 …

Then the subject is the i-th output of the i-th state of operation, the red mark as above

The first ten to write the laws can be found

  1. 1 1 1 1 1 1 1 1 1 1 1 1 1
  2. 1 0 1 0 1 0 1 0 1 0 1 0 1
  3. 1 0 0 0 1 1 1 0 0 0 1 1 1
  4. 1 0 0 1 1 1 1 1 0 0 1 0 1
  5. 1 0 0 1 0 1 1 1 0 1 1 0 1
  6. 1 0 0 1 0 0 1 1 0 1 1 1 1
  7. 1 0 0 1 0 0 0 1 0 1 1 1 1
  8. 1 0 0 1 0 0 0 0 0 1 1 1 1
  9. 1 0 0 1 0 0 0 0 1 1 1 1 1
  10. 1 0 0 1 0 0 0 0 1 0 1 1 1

In addition to n * n is 1, and the rest are all 0

Published 34 original articles · won praise 2 · Views 895

Guess you like

Origin blog.csdn.net/Kapo1/article/details/103545928