HDU 1009 FatMouse 'Trade explanations

Disclaimer: The author Jing heart, Jing space Address: http: //blog.csdn.net/kenden23/. This may not be reproduced without the consent of the author. https://blog.csdn.net/kenden23/article/details/31418535

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
 
   
13.333 31.500

Water problem greedy method,

This is difficult to understand that the individual words: of He On May GET J [I] of the JavaBeans Pounds * A% of He pays IF F. [I] * Food A% Pounds of CAT

Such expression can purchase a fraction of a few.

#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
struct twoInts
{
	int j, f;
	bool operator<(const twoInts two) const
	{
		double a = (double)j / (double)f;
		double b = (double)two.j / (double)two.f;
		return a > b;
	}
};

int main()
{
	int M, N;
	while (scanf("%d %d", &M, &N) && -1 != M)
	{
		vector<twoInts> vt(N);
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &vt[i].j);
			scanf("%d", &vt[i].f);
		}
		sort(vt.begin(), vt.end());
		double maxBean = 0.0;
		for (int i = 0; i < N; i++)
		{
			if (M >= vt[i].f)
			{
				maxBean += vt[i].j;
				M -= vt[i].f;
			}
			else
			{
				maxBean += (double)vt[i].j * M / (double)vt[i].f;
				break;
			}
		}
		printf("%.3lf\n", maxBean);
	}
	return 0;
}




Guess you like

Origin www.cnblogs.com/ldxsuanfa/p/10930058.html