Beauty of Array (find the law)

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

[Analysis] Title means to calculate a contiguous subsequence of the sequence and, if there are equal numbers, then added only once.

The sequence of eg 12343
    

1 to the end: 1

sum[1]=1=(1-0)*1

Ending 2:12 2

sum[2]=1+2+2=sum[1]+2*2=sum[1]+(2-0)*2

3 to the end: 123233

sum[3]=1+2+3+...=sum[2]+3*3=sum[2]+(3-0)*3

Ends with 4: 1234234344

sum[4]=1+2+3+...=sum[3]+4*4=sum[3]+(4-0)*4
3 to the end: 123,432,343,343,433    sum[5]=1+2+3+...=sum[4]+2*3=sum[4]+(5-3)*3
   

sum [i] = sum [i-1] + (i - pos [x]) * x; and + (this position - the position of the first occurrence number) a number on the // * (POS are initially 0, i 1 from the beginning)

 

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
int pos[100010];

int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n,x;
		ll sum = 0,ans = 0;
		scanf("%d",&n);
		memset(pos,0,sizeof(pos));
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			sum += (i-pos[x]) * x;
			ans += sum;
			pos[x] = i;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

Guess you like

Origin blog.csdn.net/qq_40912854/article/details/89062351