1090 Highest Price in Supply Chain (25分)

A supply chain is a network of retailers (retailers), distributors (dealers), and suppliers (suppliers) - everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

 

 

 

#include "iostream"

#include "vector"

using namespace std;

const int maxn=100000;

int n;

int number=0;

double price,rate;

struct node{

double price;

vector<int> child;

} Node [maxn];

 

void dfs(int node,double currentPirce){

if (Node[node].child.size()==0) {

if (currentPirce>price) {

price=currentPirce;

number=1;

}

else if(currentPirce==price){

number++;

}

return;

}

currentPirce=(1+rate/100)*currentPirce;

for (int i=0; i<Node[node].child.size(); i++) {

dfs(Node[node].child[i], currentPirce);

}

}

 

int main () {

scanf("%d %lf %lf",&n,&price,&rate);

int root;

for (int i=0; i<n; i++) {

int current;

scanf("%d",&current);

if (current==-1) {

root=i;

}

else{

Node[current].child.push_back(i);

}

}

dfs(root, price);

printf("%.2lf %d",price,number);

}

 


 

发布了13 篇原创文章 · 获赞 0 · 访问量 127

Guess you like

Origin blog.csdn.net/Yanhaoming1999/article/details/104087282