PTA Highest Price in Supply Chain (25分)

It is the human mind that releases infinite light, and it is also the human mind that creates boundless darkness. Light and darkness are intertwined and fight together. This is the world for which we are nostalgic and helpless.

A supply chain is a network of retailers (retailers), distributors, and suppliers (suppliers) - everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include<climits>//INT_MAX
//#include<bits/stdc++.h>
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
typedef long long ll;
using namespace std;
int const mod=1e9+7;
const int maxn=1e5+10;
vector<int>a[maxn];
vector<int>jg;
int n,mx;
double P,r;
void dfs(int v,int h)
{
    if(a[v].size()==0)
    {
        if(h>mx)
        {
            mx=h;
            jg.clear();
            jg.push_back(v);
        }
        else if(h==mx)
            jg.push_back(v);
        return;
    }
    for(int i=0;i<a[v].size();i++)
    {
        int u=a[v][i];
        dfs(u,h+1);
    }
}
int main()
{
    scanf("%d%lf%lf",&n,&P,&r);
    r/=100;
    int root;
    for(int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        if(x!=-1)
            a[x].push_back(i);
        else
            root=i;
    }
    dfs(root,1);
    printf("%.2f %d",P*pow(1+r,mx-1),jg.size());
    return 0;
}

 

Guess you like

Origin blog.csdn.net/weixin_44170305/article/details/108544751