PAT Grade 1079 Total Sales of Supply Chain (25 minutes)

A supply chain is a network of retailers (retailers), distributors (dealers), and suppliers (suppliers) - everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
K​i​ ID[1] ID[2] … ID[K​i​​]
where in the i-th line, K​i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​ . All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​ .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

Problem-solving ideas: Title price increase required for each layer r, so DFS variables have layer representation level. Then the conventional solution of DFS

Code:

#include<cstdio>
#include<vector>
#include<math.h>
using namespace std;
struct node{
	int data;
	vector<int> child;
}Node[100010];
int N;
double P,r,sum = 0;
void DFS(int root,int layer){
	if(Node[root].child.size() == 0){
		sum+=Node[root].data*P*pow((1+r/100),layer);
		return;
	}
	for(int i = 0;i < Node[root].child.size();i++){
		int child = Node[root].child[i];
		DFS(child,layer+1);
	}
}
int main(void){
	scanf("%d %lf %lf",&N,&P,&r);
	for(int i = 0;i < N;i++){
		int sumnum;
		scanf("%d",&sumnum);
		if(sumnum == 0)
			scanf("%d",&Node[i].data);
		else{
			for(int j = 0;j < sumnum;j++){
				int num;
				scanf("%d",&num);
				Node[i].child.push_back(num);
			}	
		}
	}
	DFS(0,0);
	printf("%.1f",sum);
	return 0;
}
Published 24 original articles · won praise 1 · views 471

Guess you like

Origin blog.csdn.net/lovingcgq/article/details/104494551