[Recurrence] Fibonacci Again

description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Entry

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Export

Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

Source title

HDOJ
分析:斐波那契递推。
代码:
#include<bits/stdc++.h>
using namespace std;
int f[1000001];
void Fibo()
{
f[0]=7;f[1]=11;
for (int i=2;i<1000001;i++)
f[i]=(f[i-1]+f[i-2])%3;
}
int main()
{
Fibo();
int n;
while(cin>>n)
{
if (f[n]%3==0)
cout<<“yes”<<endl;
else
cout<<“no”<<endl;
}
return 0;
}

Published 69 original articles · won praise 0 · Views 1765

Guess you like

Origin blog.csdn.net/Skynamer/article/details/104079423