HDU 1021 Fibonacci Again

Title Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no

Problem-solving ideas

When a start solving the problem, the direct use of awkward, did not go to law, and later learned that this question is regular, in fact, as long as n is divided by 42 this condition, is yes, otherwise, is no.

AC Code

#include <bits/stdc++.h>

using namespace std;

int main()
{
	int n;
	while(cin>>n)
	{
		if(n%4==2)
		{
			cout<<"yes"<<endl;
		}
		else
		{
			cout<<"no"<<endl;
		}
	}
	return 0;
 
} 
Published 113 original articles · won praise 103 · views 10000 +

Guess you like

Origin blog.csdn.net/Deep___Learning/article/details/103995320