AreYouBusy HDU - 3535 (mixed backpack)

Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?
Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
Sample Output
5
13
-1
-1

The meaning of problems:
many groups there are some items, valuable and cost v w.
Backpack capacity of T.
Each selection is limited, at least some of a selected, some at most a selected, some may be arbitrarily selected.
How much demand hold up.
Ideas:

  • At least choose one. Choose start state transition (state had been transferred over selected, then at least one selected from the group, a number of possible options), and transferred (this only selected a) from a set state and
  • Up to choose one. Transferred directly from the collector and a state can be a
  • Pick. The equivalent of doing 01 in this group backpack.
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
int dp[105][105];

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        for(int i = 1;i <= n;i++)
        {
            int num,cnt;scanf("%d%d",&num,&cnt);
            if(cnt == 0)//至少选一个
            {
                for(int j = 0;j <= m;j++)dp[i][j] = -INF;
                for(int j = 1;j <= num;j++)
                {
                    int w,v;scanf("%d%d",&w,&v);
                    for(int k = m;k >= w;k--)
                    {
                        dp[i][k] = max(dp[i][k],dp[i][k - w] + v);//当前集和选,从”至少选了一个“的状态转移过来。
                        dp[i][k] = max(dp[i][k],dp[i - 1][k - w] + v);//至少选了一个,和只选了一个的状态。
                    }
                }
            }
            else if(cnt == 1)//至多选一个
            {
                for(int j = 0;j <= m;j++)dp[i][j] = dp[i - 1][j];
                for(int j = 1;j <= num;j++)
                {
                    int w,v;scanf("%d%d",&w,&v);
                    for(int k = m;k >= w;k--)
                    {
                        dp[i][k] = max(dp[i][k],dp[i - 1][k - w] + v);//上一个集合选,为选了一个
                    }
                }
            }
            else if(cnt == 2)//随便选
            {
                for(int j = 0;j <= m;j++)dp[i][j] = dp[i - 1][j];
                for(int j = 1;j <= num;j++)
                {
                    int w,v;scanf("%d%d",&w,&v);
                    for(int k = m;k >= w;k--)
                    {
                        dp[i][k] = max(dp[i][k],dp[i][k - w] + v);//普通01背包
                    }
                }
            }
        }
        dp[n][m] = max(dp[n][m],-1);
        printf("%d\n",dp[n][m]);
    }
    return 0;
}

Published 594 original articles · won praise 16 · views 20000 +

Guess you like

Origin blog.csdn.net/tomjobs/article/details/103986719