HDU-5534 Partial Tree (complete backpack)

In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree. 

You find a partial tree on the way home. This tree has nn nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are n−2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where ff is a predefined function and dd is the degree of this node. What's the maximum coolness of the completed tree?

Input

The first line contains an integer T indicating the total number of test cases. 
Each test case starts with an integer n in one line, 
then one line with n−1 integers f(1),f(2),…,f(n−1)

1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n>100

Output

For each test case, please output the maximum coolness of the completed tree in one line.

Sample Input

2
3
2 1
4
5 1 4

Sample Output

5
19

Question: Construct a tree, the degree of each point is ai, find the maximum value of f(a1) + ... + f(an)

Idea: The total degree of a tree with n points is 2 * n-2, and each point is divided into one degree (definitely), and the remaining n-2 degrees are used as the backpack capacity, and the degree is 0 ~ n-2 Seen as n-1 items, it becomes a naked complete backpack

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int N = 2020;

int dp[2 * N], f[N];

int main() {
    int t, n;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 1; i < n; ++i) scanf("%d", &f[i]);
        for(int i = 0; i < N; ++i) dp[i] = -inf;
        dp[0] = 0;
        for(int i = 1; i < n - 1; ++i) {
            for(int j = i; j <= n - 2; ++j) {
                dp[j] = max(dp[j], dp[j - i] + f[i + 1] - f[1]);
            }
        }
        printf("%d\n", dp[n - 2] + n * f[1]);
    }
	return 0;
}

 

Guess you like

Origin blog.csdn.net/weixin_43871207/article/details/109855587