01 Backpack: HDU2602Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

The meaning of problems:
The first group of rows of input examples, three lines and then
the second row are input N, V capacity and the number of packets representative of bone
third line of the input value of each bone
fourth line input capacity of each bone

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
//HDU2602Bone Collector
int main()
{
    int z,N,V;
    int i,j;
    int f[100]={0};
    int vg[100]={0};
    int rg[100]={0};
    while(scanf("%d",&z)!=EOF){//输入组数
        scanf("%d%d",&N,&V);
        //再依次输入骨头价值和容量
        for(i=0;i<N;i++)
            scanf("%d",&vg[i]);
        for(i=0;i<N;i++)
            scanf("%d",&rg[i]);
            //再开始输入背包
        for(i=0;i<N;i++)
            for(j=V;j>=rg[i];j--)//逆序表达
                f[j]=max(f[j],f[j-rg[i]]+vg[i]);
        printf("%d\n",f[V]);
    }
}




Published 72 original articles · won praise 5 · Views 2812

Guess you like

Origin blog.csdn.net/qq_41115379/article/details/104919758