About an enterprise switching and routing jobs

First, the basic configuration:

Core switches LSW9 the vlan 1 configured with an IP address 192.168.221.2/24, the operation code is as follows:

 interface  vlanif 1

ip address 192.168.221.2  24

 

Core switches LSW6 the vlan 1 configured with an IP address 172.16.221.2/24, the operation code is as follows:

 interface  vlanif 1

ip address 172.16.221.2 24

 

Core switches LSW8 the vlan 1 configured with an IP address 172.18.221.2/24, the operation code is as follows:

 interface  vlanif 1

ip address 172.18.221.2 24

 

Router R6 is G 0/0/0 port configured with the IP address: 172.17.221.1/24,

G 0/0/1 port configured with the IP address: 192.168.221.1/24,

Operation code is as follows:

interface GigabitEthernet 0/0/0

ip address 172.17.221.1 24

interface GigabitEthernet 0/0/1

ip address 192.168.221.1 24

 

Router R5 is G 0/0/0 port configured with the IP address: 172.17.221.2/24,

G 0/0/1 port configured with the IP address: 172.18.221.1/24,

G 0/0/2 port configured with the IP address: 172.16.221.1/24,

 

Operation code is as follows:

interface GigabitEthernet 0/0/0

ip address 172.17.221.2 24

interface GigabitEthernet 0/0/1

ip address 172.18.221.1 24

interface GigabitEthernet 0/0/2

ip address 172.16.221.1 24

Second, create the access switch Vlan, interfaces to the Vlan planning to join in:

Determined and divided according to the number of the corporate sector the number of vlan, here is divided into vlan 10 20 30 40 50. Configuration commands are as follows:

LSW2 switch connects to a host vlan10 therefore vlan10 created, and join the two hosts, the operation code as follows:

vlan 10

quit

interface Ethernet 0/0/1

port link-type access

port default vlan 10

interface Ethernet 0/0/2

port link-type access

port default vlan 10

Configure GE 0/0/1 interface allowing vlan10 through, the operation code as follows:

interface GigabitEthernet  0/0/1

port link-type trunk

port trunk allow-pass vlan 10

 

 

 

 

 

LSW1 switch connects to a host vlan20, vlan30, thus creating vlan20,30, was added and the two hosts, the operation code as follows:

vlan  batch 20 30

quit

interface Ethernet 0/0/1

port link-type access

port default vlan 20

interface Ethernet 0/0/2

port link-type access

port default vlan 30

Configure GE 0/0/2 interface allowing vlan20,30 through, the operation code as follows:

interface GigabitEthernet 0/0/2

port link-type trunk

port trunk allow-pass vlan 20 30

 

LSW4 switches connected host vlan40, vlan50, thus creating vlan40, vlan50, and added three hosts, the operation code as follows:

vlan batch 40 50

quit

interface Ethernet 0/0/2

port link-type access

port default vlan 40

interface Ethernet 0/0/1

port link-type access

port default vlan 50

interface Ethernet 0/0/3

port link-type access

port default vlan 50

Configure GE 0/0/2 interface allowing vlan40, vlan50 by the operation code is as follows:

interface Ethernet 0/0/2

port link-type trunk

port trunk allow-pass vlan 40 50

 

 

First, the configuration switches in the core business gateway address of Vlan:

Vlan gateway address in the core needs to switch configuration, the specific configuration is as follows:

In the core switch LSW9 creation vlan10, and allowed to pass vlan10 into vlan10, configure the gateway address, operation code is as follows:

vlan 10

quit

interface GigabitEthernet 0/0/24

port link-type trunk

port trunk allow-pass vlan 10

interface Vlanif 10

ip address 10.221.11.254 23

 

In the core switch LSW6 creation vlan20,30, and allowed to pass vlan20,30 into vlan20,30, configure the gateway address, operation code is as follows:

vlan batch 20 30

interface GigabitEthernet 0/0/23

port link-type trunk

port trunk allow-pass vlan 20 30

interface Vlanif 20

ip address10.221.20.254 24

interface Vlanif  30

ip address 10.221.30.254 24

 

 

 

 

 

Core switches in creating the vlan40,50 S3, and allowed to pass vlan40,50 into vlan40,50, configure the gateway address, operation code is as follows:

Vlan batch 40 50

quit

interface GigabitEthernet 0/0/23

port link-type trunk

port trunk allow-pass vlan 40 50

interface Vlanif 40

ip address 10.221.40.254 24

interface Vlanif 50

ip address 10.221.51.254 23

 

Second, the core link aggregation switch configuration:

I use a link aggregation between LSW9 and LSW2, the specific configuration is as follows:

 

Create and link aggregation between LSW9 LSW2, the operation code is as follows:

LSW9:

int Eth-Trunk 1

port link-type trunk

port trunk allow-pass vlan 10

eth-trunk 1

LSW2:

int Eth-Trunk 1

port link-type trunk

port trunk allow-pass vlan 10

eth-trunk 1

 

 

 

 

 

 

Third, in the switch configuration Spanning Tree Protocol :

According to subject, I use LSW1, LSW4, LSW6, LSW8 four switches to create a spanning tree protocol

Operation code is as follows:

LSW1, LSW4, LSW6, LSW8 are:

stp enable

stp stp fashion

Spanning Tree Protocol is turned on, and the mode is set to stp Spanning Tree Protocol

 

 

Fourth, configure IPv4 routing protocols :

Core switch LSW9:

ip route-static 10.221.20.0 255.255.255.0 192.168.221.1

ip route-static 10.221.30.0 255.255.255.0 192.168.221.1

ip route-static 10.221.40.0 255.255.255.0 192.168.221.1

ip route-static 10.221.50.0 255.255.254.0 192.168.221.1

 

Core switch LSW6:

ip route-static 10.221.10.0 255.255.254.0 172.16.221.1

ip route-static 10.221.40.0 255.255.255.0 172.16.221.1

ip route-static 10.221.50.0 255.255.254.0 172.16.221.1

 

Core switch LSW8:

ip route-static 10.221.10.0 255.255.254.0 172.18.221.1

ip route-static 10.221.20.0 255.255.255.0 172.18.221.1

ip route-static 10.221.30.0 255.255.255.0 172.18.221.1

 

Router R6:

ip route-static 10.221.10.0 255.255.254.0 192.168.221.2

ip route-static 10.221.20.0 255.255.255.0 172.17.221.2

ip route-static 10.221.30.0 255.255.255.0 172.17.221.2

ip route-static 10.221.40.0 255.255.255.0 172.17.221.2

ip route-static 10.221.50.0 255.255.254.0 172.17.221.2

 

 

Router R5:

ip route-static 10.221.10.0 255.255.254.0 172.17.221.1

ip route-static 10.221.20.0 255.255.255.0 172.16.221.2

ip route-static 10.221.30.0 255.255.255.0 172.16.221.2

ip route-static 10.221.40.0 255.255.255.0 172.18.221.2

ip route-static 10.221.50.0 255.255.254.0 172.18.221.2

 

Guess you like

Origin www.cnblogs.com/a-1187629089/p/11951689.html