1015 Reversible Primes (20 分)

Disclaimer: This article is a blogger original article, follow the CC 4.0 BY-SA copyright agreement, reproduced, please attach the original source link and this statement.
This link: https://blog.csdn.net/weixin_42582136/article/details/102653070

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

#include<bits/stdc++.h>
using namespace std;
bool is_prime(long long n) {
	if (n < 2) return  false;
	for (int i = 2; i <= sqrt(n); i++)
		if (n % i == 0) return false;
	return true;
}
int rev(int m, int n) {
	vector<int>re;
	string str;
	while (m) {
		re.push_back(m % n);
		m /= n;
	};
	reverse(re.begin(), re.end());
	int sum = 0;
	for (int i = 0; i < re.size(); i++)
		sum += pow(n, i) * re[i];
	return sum;
}
int main()
{
	int m, n;
	vector<string>re;
	while (cin >> m && m >= 0){
		cin >> n;
		cout << (is_prime(m) && is_prime(rev(m, n)) ? "Yes" : "No") << endl;
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_42582136/article/details/102653070