HDU 1700 Points on Cycle (coordinate rotation)

Topic links: HDU 1700

Problem Description

There is a cycle with its center on the origin.

Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other

you may assume that the radius of the cycle will not exceed 1000.

Input

There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.

Output

For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision

Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X.

NOTE

when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.

Sample Input

2
1.500 2.000
563.585 1.251

Sample Output

0.982 -2.299 -2.482 0.299
-280.709 -488.704 -282.876 487.453

Source

2007 Provincial Race Team practice session (1)

Solution

The meaning of problems

Given a circular dot in a circle and the origin of the circle, two points to find another such that the three dots on the circular perimeter of the triangle maximum.

Thinking

Coordinate rotation

Coordinate rotation template title.

Triangle is an equilateral triangle is the largest circumference.

Give rotation about the origin point specified \ (120 ° \) and \ (240 ° \) can.

Code

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef double db;
const db eps = 1e-10;
const db pi = acos(-1.0);
const ll inf = 0x3f3f3f3f3f3f3f3f;
const ll maxn = 1e5 + 10;

inline int dcmp(db x) {
    if(fabs(x) < eps) return 0;
    return x > 0? 1: -1;
}

class Point {
public:
    double x, y;
    Point(double x = 0, double y = 0) : x(x), y(y) {}
    void input() {
        scanf("%lf%lf", &x, &y);
    }
    bool operator<(const Point &a) const {
        return (!dcmp(y - a.y))? dcmp(x - a.x) < 0: y < a.y;
    }
    Point Rotate(double rad) {
        return Point(x * cos(rad) - y * sin(rad), x * sin(rad) + y * cos(rad));
    }
};

Point ans[2];

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        Point p;
        p.input();
        double r = 2.0 * pi / 3.0;
        ans[0] = p.Rotate(r);
        ans[1] = p.Rotate(r * 2);
        sort(ans, ans + 2);
        printf("%.3lf %.3lf %.3lf %.3lf\n", ans[0].x, ans[0].y, ans[1].x, ans[1].y);
    }
    return 0;
}

Guess you like

Origin www.cnblogs.com/wulitaotao/p/11604834.html
Recommended