B - How Many Equations Can You Find dfs

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

InputEach case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.OutputThe output contains one line for each data set : the number of ways you can find to make the equation.Sample Input

123456789 3
21 1

Sample Output

18 is 
. 1 

subject to the effect that a + is added between the two numbers - a number of processing or not so that he can get back, and record the number of times like
the idea: DFS through each case
#include<iostream>
#include<string >
using namespace std;
string a;
typedef long long ll;
ll n,ans;
void dfs(int row,int sum){
    if(row==a.size())
    {
        if(sum==n)
            ans++;
        return ;
    }
    
    ll t=0;
    for(int i=row;i<a.size();i++)
    {
        tT * = 10 + A [I] - ' 0 ' ; 
        DFS (I + . 1 , SUM + T);
         IF (== Row 0 ) Continue; // because when row == 0 when sum = 0, such as over-subtraction number of words corresponds to a minus number in front of the first number, so to skip 
     DFS (I + . 1 , SUM-T); } } int main () { the while (CIN >> a >> n-) { ANS = 0 ; DFS ( 0 , 0 ); COUT << ANS << endl; } return 0 ; }

 

Guess you like

Origin www.cnblogs.com/Accepting/p/11242112.html