HCL-6to4 automatic tunnel experiment

6to4 automatic tunnel

Features:

  1. It is an automatic point-to-multipoint tunnel, mainly used to connect multiple IPv6 islands to IPv6 networks through IPv4 networks.
  2. The 6to4 tunnel must use a special 6to4 address, whose format is 2002:abcd:efgh:subnet number:∵:interface ID, where 2002 represents a fixed IPv6 address prefix, and abcd:efgh is an IPv4 address expressed in hexadecimal (such as 1.1.1.1 can be expressed as 0101:0101) , which is used to uniquely identify a 6to4 network. The end point of the tunnel can be automatically determined through this embedded IPv4 address, making tunnel establishment very convenient.
  3. There is no need to pre-configure the destination IPv4 address for each tunnel. The system obtains it from the 6to4 address.

experiment procedure

R1 establishes a 6to4 tunnel with R2 and R3

R1

Basic configuration:

interface GigabitEthernet0/0
 ip address 10.10.10.1 255.255.255.252

ip route-static 0.0.0.0 0 10.10.10.2

Tunnel configuration

interface Tunnel0 mode ipv6-ipv4 6to4

source GigabitEthernet0/0

ipv6 address 2002:A0A:A01::1/64

Static routing configuration

ipv6 route-static 2002:: 16 Tunnel0

R2

Basic configuration:

interface GigabitEthernet0/0
 ip address 20.20.20.1 255.255.255.252

ip route-static 0.0.0.0 0 20.20.20.2

Tunnel configuration

interface Tunnel0 mode ipv6-ipv4 6to4
 source GigabitEthernet0/0
 ipv6 address 2002:1414:1401::1/64

Static routing configuration

ipv6 route-static 2002:: 16 Tunnel0

R3

Basic configuration:

interface GigabitEthernet0/0
 ip address 30.30.30.1 255.255.255.252

ip route-static 0.0.0.0 0 30.30.30.2

Tunnel configuration

interface Tunnel0 mode ipv6-ipv4 6to4

source GigabitEthernet0/0

ipv6 address 2002:1E1E:1E01::1/64

Static routing configuration

ipv6 route-static 2002:: 16 Tunnel0

R1 performs ping test

The experiment is successful and ends here

Guess you like

Origin blog.csdn.net/m0_62621003/article/details/132876937