The maximum value of the product (greedy thinking)

question

给出两个集合,各选出n个元素,求乘积最大值、
1037 Magic Coupon (25 分)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N
C

, followed by a line with N
C

coupon integers. Then the next line contains the number of products N
P

, followed by a line with N
P

product values. Here 1≤N
C

,N
P

≤10
5
, and it is guaranteed that all the numbers will not exceed 2
30
.

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
No blank line at the end
Sample Output:
43

train of thought

Separate the positive and negative numbers of the two sets, sort the positive numbers from large to small, and sort the negative numbers from small to large. The corresponding positions are multiplied together to obtain the maximum value.

the code

#include<bits/stdc++.h>
using namespace std;

vector<int> set1_pos,set2_pos,set1_neg,set2_neg;
bool cmp(int a,int b){
    
    
    return a>b;
}
int main(){
    
    
    int n1,n2,temp;
    cin>>n1;
    for (int i = 0; i < n1; ++i) {
    
    
        cin>>temp;
        if(temp>=0){
    
    
            set1_pos.push_back(temp);
        } else{
    
    
            set1_neg.push_back(temp);
        }
    }
    cin>>n2;
    for (int j = 0; j < n2; ++j) {
    
    
        cin>>temp;
        if(temp>=0){
    
    
            set2_pos.push_back(temp);
        } else{
    
    
            set2_neg.push_back(temp);
        }
    }
    int len1 = min(set1_pos.size(),set2_pos.size());
    int len2 = min(set1_neg.size(),set2_neg.size());
    sort(set1_pos.begin(),set1_pos.end(),cmp);
    sort(set2_pos.begin(),set2_pos.end(),cmp);
    sort(set1_neg.begin(),set1_neg.end());
    sort(set2_neg.begin(),set2_neg.end());
    int ans = 0;
    for (int k = 0; k < len1; ++k) {
    
    
        ans = ans + set1_pos[k]*set2_pos[k];
    }
    for (int l = 0; l < len2; ++l) {
    
    
        ans = ans + set1_neg[l]*set2_neg[l];
    }
    cout<<ans;
    return 0;
}

Summarize

The time limit for this question is wide, and the sort function is used four times.

Guess you like

Origin blog.csdn.net/qq_19272233/article/details/119427875