The principle and configuration of the most detailed static routing

Chapter 4: Static Routing

Forwarding data packets is the most important function of routers. When a router forwards a data packet, it needs to look up the routing table. The administrator can directly configure the routing table in the router manually. This is a static route. Although static routing is not suitable for use in large networks, it is often used in many occasions due to its simplicity, small router load, and strong controllability.

4.1 Overview of Static Routing

Static routes are easy to configure and are widely used in networks. In addition, static routing can also implement load balancing and routing backup. Therefore, it is very necessary to learn and master the application and configuration of static routing.

  1. Ways to Obtain Routing Information
  • Directly connected route: The route of the network segment where the directly connected interface is located is automatically generated by the device.
  • Static routing: Routing entries manually configured by network administrators
  • Dynamic routing: Routes learned by routers through dynamic routing protocols (such as OSPF, IS-IS, BGP, etc.)

RIP: Routing Information Protocol Routing Information Protocol

OSPF: Open Shortest Path First Open Shortest Path First

IS-IS: Intermediate system to intermediate system Intermediate system to intermediate system

BGP: Border Gateway Protocol Border Gateway Protocol

  1. Parameters of the routing table
  • Destination/Mask: Indicates the destination network address and netmask of this route. After "logic AND" the destination address and the subnet mask, the address of the network segment where the destination host or router is located can be obtained. For example: the destination address is 1.1.1.1, the address of the network segment where the host or router is located is 1.1.1.0 and the mask is 255.255.255.0.
  • Proto (Protocol): The protocol type of the route, that is, the protocol through which the router learns the route.
  • Pre (Preference): Indicates the routing protocol priority of this route. For the same destination, there may be multiple routes with different next hops and outgoing interfaces. These different routes may be discovered by different routing protocols, or they may be manually configured static routes. The one with the highest priority (smallest value) will be the current optimal route.
  • Cost: Routing cost. When multiple routes to the same destination have the same route priority, the route with the smallest cost will be the current optimal route.
  • NextHop: For this router, the next hop address to reach the destination network pointed to by this route. This field indicates the next device for data forwarding.
  • Interface: Indicates the outbound interface of this route. Indicates which interface of the router the data will be forwarded from.

  1. preference

Table 4-1 lists the preferences of various protocols

Table 4-1 : Preference of various protocols

routing source

routing type

default priority

direct connection

direct route

0

static

static route

60

dynamic routing

RIP

100

OSPF

10 inside, 150 outside

IS-IS

15

BGP

IBGP255 ,EBGP255

  1. The best routing entry takes precedence

When the router learns the route to the same destination network segment from different ways, it will prioritize the route by comparing the priority and metric value :

  • Compare priorities, the lower the priority, the higher the priority
  • The priority is the same, compare the measurement value, the smaller the measurement value, the higher the priority
  1. longest match principle

When the router receives an IP data packet, it will compare the destination IP address of the data packet with all routing table entries in its local routing table (Bit-By-Bit) until it finds the entry with the longest matching degree. , which is the longest prefix matching mechanism.

4.2 Experiment 1: Static Routing

1. Experimental requirements

① Grasp the concept of routing table;

② Master the use of the route-static command;

③ Understand the correct configuration of static routing according to requirements.

2. Experimental topology

The experimental topology is shown in Figure 4-1:

Figure 4-1 Static routing

3. Experimental steps

(1) Network connectivity

The configuration of R1 is as follows:

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R1

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24

[R1-GigabitEthernet0/0/0]undo shutdown

[R1-GigabitEthernet0/0/0]quit

The configuration of R2 is as follows:

<Huawei>system-view

[Huawei]undo info-center enable

[Huawei]sysname R2

[R2]interface g0/0/1

[R2-GigabitEthernet0/0/1]ip address 12.1.1.2 24

[R2-GigabitEthernet0/0/1]undo shutdown

[R2-GigabitEthernet0/0/1]quit

[R2]interface g0/0/0

[R2-GigabitEthernet0/0/0]ip address 23.1.1.2 24

[R2-GigabitEthernet0/0/0]undo shutdown

[R2-GigabitEthernet0/0/0]quit

The configuration of R3 is as follows:

<Huawei>system-view

[Huawei]undo info-center enable

[Huawei]sysname R3

[R3]interface g0/0/1

[R3-GigabitEthernet0/0/1]ip address 23.1.1.3 24

[R3-GigabitEthernet0/0/1]undo shutdown

[R3-GigabitEthernet0/0/1]quit

(2) Test network connectivity

R1 visits R2

[R1]ping 12.1.1.2

  PING 12.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from 12.1.1.2: bytes=56 Sequence=1 ttl=255 time=60 ms

    Reply from 12.1.1.2: bytes=56 Sequence=2 ttl=255 time=60 ms

    Reply from 12.1.1.2: bytes=56 Sequence=3 ttl=255 time=50 ms

    Reply from 12.1.1.2: bytes=56 Sequence=4 ttl=255 time=40 ms

    Reply from 12.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms

  --- 12.1.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 30/48/60 ms

   From the display results of ping, it can be seen that there is no problem with the network connectivity.

  

R2 visits R3

    [R2]ping 23.1.1.3

  PING 23.1.1.3: 56  data bytes, press CTRL_C to break

    Reply from 23.1.1.3: bytes=56 Sequence=1 ttl=255 time=70 ms

    Reply from 23.1.1.3: bytes=56 Sequence=2 ttl=255 time=40 ms

    Reply from 23.1.1.3: bytes=56 Sequence=3 ttl=255 time=60 ms

    Reply from 23.1.1.3: bytes=56 Sequence=4 ttl=255 time=30 ms

    Reply from 23.1.1.3: bytes=56 Sequence=5 ttl=255 time=20 ms

  --- 23.1.1.3 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 20/44/70 ms

    From the ping results, it can be seen that there is no problem with network connectivity.

   【Technical points】

      For beginners, after configuring the IP address each time, it is best to test the connectivity of the network according to the above method. Use this to confirm whether there is a problem with the IP address configuration. If the network cannot be accessed, there may be the following problems:

  • If the interface is not enabled, the displayed result is shown in Figure 4-2, and "*down" is displayed under Physical.

                                                       Figure 4-2 The interface is not opened

  • There is no IP address configured on the pull port or the IP address is configured incorrectly, the display result is shown in Figure 4-3, and it is displayed as "unassigned" under IP Address/Mask

                                                     Figure 4-3 No IP address configured

(2) Configure static routing

Configuration of R1:

[R1]ip route-static 23.1.1.0 255.255.255.0 12.1.1.2 // Configure the static routing directory network as 23.1.1.0 and the next hop as 12.1.1.2

      【Technical points】

   There are three ways to configure static routing

① The way to associate the next hop

[Huawei] ip route-static ip-address { mask | mask-length } nexthop-address

②The method of associating the outbound interface

[Huawei] ip route-static ip-address { mask | mask-length } interface-type interface-number

③The method of associating the interface with the next hop

[Huawei] ip route-static ip-address { mask | mask-length } interface-type interface-number [ nexthop-address ]

  When creating a static route, you can specify both the outgoing interface and the next hop. For different types of outbound interfaces, you can specify only the outbound interface or only the next hop.

For a point-to-point interface (such as a serial port), only the outgoing interface needs to be specified.

For broadcast interfaces (such as Ethernet interfaces) and VT (Virtual-template) interfaces, the next hop must be specified.

For Ethernet, if you want to successfully encapsulate the data frame, you must know the mac address of the next hop ip address. If you do not specify the next hop address but only specify the outgoing interface, the device cannot obtain the mac address of the next hop through the arp protocol. Thus, the encapsulation of the data frame cannot be completed. WAN protocol encapsulation frame does not need mac address, which will be introduced in later courses, so the next hop address must be specified for the Ethernet interface.

To sum up, there are three theoretical configuration methods for static routing on R1:

[R1]ip route-static 23.1.1.0 255.255.255.0 12.1.1.2 // Associate next hop

[R1]ip route-static 23.1.1.0 255.255.255.0 g0/0/0 // associated outgoing interface  

[R1]ip route-static 23.1.1.0 255.255.255.0 g0/0/0 12.1.1.2 // Associate outgoing interface and next hop

Configuration of R3:

[R3]ip route-static 12.1.1.0 24 23.1.1.2

4. Experimental debugging

  (1) Check the routing table on R1

[R1]display ip routing-table // View the routing table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 5        Routes : 5       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       12.1.1.0/24         Direct  0    0           D   12.1.1.1        GigabitEthernet0/0/0

       12.1.1.1/32         Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0

       23.1.1.0/24         Static  60   0          RD   12.1.1.2        GigabitEthernet0/0/0

      127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

      127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

   The above output can be seen that there is a static route of 23.1.1.0/24 in the routing table

  【Technical points】

      Let's look at the route 23.1.1.0, and the various parameters are analyzed as follows:

  • Destination/Mask: 23.1.1.0/24 //The destination network is 23.1.1.0, and the subnet mask is 255.255.255.0
  • Proto: Static // This route is learned through static routing
  • Pre: 60 //The priority of the static route is 60
  • Cost: 0 //The routing cost is 0
  • Flags: RD //where R means that this routing entry is an iterative routing entry, and D means that this routing entry is sent to the FIB table
  • NextHop: 12.1.1.2 //The next hop of the route is 12.1.1.2
  • Interface: GigabitEthernet0/0/0 //The outgoing interface of the route is g0/0/0

(2) Check the routing table on R2

<R2>display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 6        Routes : 6       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       12.1.1.0/24  Direct  0    0           D   12.1.1.2        GigabitEthernet0/0/1

       12.1.1.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1

       23.1.1.0/24  Direct  0    0           D   23.1.1.2        GigabitEthernet0/0/0

       23.1.1.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0

      127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

      127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

【think】

  Why is there no static route configured on R2?

  Analysis: Because R2 has direct routes of 12.1.1.0/24 and 23.1.1.0/24

【Technical points】

The direct route is discovered by the data link layer protocol, which refers to the path to the network segment where the interface address of the router is located. When the interface is activated, the router will fill in the routing information of the network segment where the directly connected interface is located in the routing table. The link layer can only discover the route of the directly connected network segment where the interface is located, but cannot discover the route of the inter-network segment. Routes across network segments need to be obtained by other methods.

(3) Check the routing table on R3

<R3>display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 5        Routes : 5       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       12.1.1.0/24  Static  60   0          RD   23.1.1.2        GigabitEthernet0/0/1

       23.1.1.0/24  Direct  0    0           D   23.1.1.3        GigabitEthernet0/0/1

       23.1.1.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/1

      127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

      127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

 (4) R1 visits R3

  <R1>ping 23.1.1.3

  PING 23.1.1.3: 56  data bytes, press CTRL_C to break

    Reply from 23.1.1.3: bytes=56 Sequence=1 ttl=254 time=70 ms

    Reply from 23.1.1.3: bytes=56 Sequence=2 ttl=254 time=60 ms

    Reply from 23.1.1.3: bytes=56 Sequence=3 ttl=254 time=80 ms

    Reply from 23.1.1.3: bytes=56 Sequence=4 ttl=254 time=50 ms

    Reply from 23.1.1.3: bytes=56 Sequence=5 ttl=254 time=50 ms

  --- 23.1.1.3 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 50/62/80 ms

   From the ping results, we can see that R1 can access R3.

4.3 Experiment 2 : Default route

  1. Purpose

① The use of the default route;

② Default route configuration

  1. experimental topology

The experimental topology is shown in Figure 4-4

                                        Figure 4-4 Default route

  1. Experimental procedure
  1. Configure network connectivity

Configuration of R1

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R1

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24

[R1-GigabitEthernet0/0/0]undo shutdown

[R1-GigabitEthernet0/0/0]quit

Configuration of R2

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R2

[R2]interface g0/0/1

[R2-GigabitEthernet0/0/1]ip address 12.1.1.2 24

[R2-GigabitEthernet0/0/1]undo shutdown

[R2-GigabitEthernet0/0/1]quit

[R2]interface g0/0/0

[R2-GigabitEthernet0/0/0]ip address 23.1.1.2 24

[R2-GigabitEthernet0/0/0]undo shutdown

[R2-GigabitEthernet0/0/0]quit

[R2]interface g0/0/2

[R2-GigabitEthernet0/0/2]ip address 24.1.1.2 24

[R2-GigabitEthernet0/0/2]undo shutdown

[R2-GigabitEthernet0/0/2]quit

Configuration of R3

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R3

[R3]interface g0/0/1

[R3-GigabitEthernet0/0/1]ip address 23.1.1.3 24

[R3-GigabitEthernet0/0/1]undo shutdown

[R3-GigabitEthernet0/0/1]quit

Configuration of R4

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R4

[R4]interface g0/0/1

[R4-GigabitEthernet0/0/1]ip address 24.1.1.4 24

[R4-GigabitEthernet0/0/1]undo shutdown

[R4-GigabitEthernet0/0/1]quit

  1. Configure static routing

 Configuration of R1

[R1]ip route-static 0.0.0.0 0.0.0.0 12.1.1.2 // Configure the default route to any network segment with the next hop as 12.1.1.2

   【Technical points】

     In this experiment, if we use static routing, then we need to configure two static routes, the specific configuration is as follows:

[R1]ip route-static 23.1.1.0 255.255.255.0 12.1.1.2

[R1]ip route-static 24.1.1.0 255.255.255.0 12.1.1.2

   Readers think about it, if there are 1000 routes, our configuration is not particularly complicated, so readers can use the default route to simplify the configuration for multiple static routes with the same next hop.

 Configuration of R3

[R3]ip route-static 12.1.1.0 255.255.255.0 23.1.1.2

         Configuration of R4

[R4]ip route-static 12.1.1.0 255.255.255.0 24.1.1.2

  1. Experimental debugging

               View the routing table of R1

[R1]display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 5        Routes : 5       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        0.0.0.0/0   Static  60   0          RD   12.1.1.2        GigabitEthernet0/0/0

       12.1.1.0/24  Direct  0    0           D   12.1.1.1        GigabitEthernet0/0/0

       12.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet0/0/0

      127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

      127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

   By viewing the routing table of R1, the reader can see a default route. Although the configuration is simplified, the reader tests the network connectivity.

   R1 visits R3

[R1]ping 23.1.1.3

  PING 23.1.1.3: 56  data bytes, press CTRL_C to break

    Reply from 23.1.1.3: bytes=56 Sequence=1 ttl=254 time=100 ms

    Reply from 23.1.1.3: bytes=56 Sequence=2 ttl=254 time=60 ms

    Reply from 23.1.1.3: bytes=56 Sequence=3 ttl=254 time=50 ms

    Reply from 23.1.1.3: bytes=56 Sequence=4 ttl=254 time=70 ms

    Reply from 23.1.1.3: bytes=56 Sequence=5 ttl=254 time=80 ms

  --- 23.1.1.3 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 50/72/100 ms

   R1 visits R4

[R1]ping 24.1.1.4

  PING 24.1.1.4: 56  data bytes, press CTRL_C to break

    Reply from 24.1.1.4: bytes=56 Sequence=1 ttl=254 time=60 ms

    Reply from 24.1.1.4: bytes=56 Sequence=2 ttl=254 time=90 ms

    Reply from 24.1.1.4: bytes=56 Sequence=3 ttl=254 time=60 ms

    Reply from 24.1.1.4: bytes=56 Sequence=4 ttl=254 time=80 ms

    Reply from 24.1.1.4: bytes=56 Sequence=5 ttl=254 time=80 ms

  --- 24.1.1.4 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 60/74/90 ms

   Through the test, readers can see that although the default route simplifies configuration, it does not affect access, so readers can consider using the default route when encountering similar topologies in the future.

Experiment video guide:

Course - Huawei Datacom Certification HCIA System Learning Course - Zhuo Yingyun Classroom https://ke.joinlabs3.com/course/27

4.3 Experiment 3: Floating Static Routing

  1. Purpose
  • Usage Scenarios for Floating Static Routes
  • Configuration of floating static routes
  1. experimental topology

The experimental topology is shown in Figure 4-5

                                        Figure 4-5 Floating static routes

  1. Experimental procedure

(1) Network connectivity

Configuration of R1

[Huawei]sysname R1

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24

[R1-GigabitEthernet0/0/0]undo shutdown

[R1-GigabitEthernet0/0/0]quit

[R1]interface g0/0/1

[R1-GigabitEthernet0/0/1]ip address 10.1.1.1 24

[R1-GigabitEthernet0/0/1]undo shutdown

[R1-GigabitEthernet0/0/1]quit

Configuration of R2

<Huawei>system-view

Enter system view, return user view with Ctrl+Z.

[Huawei]undo info-center enable

[Huawei]sysname R2

[R2]interface g0/0/0

[R2-GigabitEthernet0/0/0]ip address 12.1.1.2 24

[R2-GigabitEthernet0/0/0]undo shutdown

[R2-GigabitEthernet0/0/0]quit

[R2]interface g0/0/1

[R2-GigabitEthernet0/0/1]ip address 10.1.1.2 24

[R2-GigabitEthernet0/0/1]undo shutdown

[R2-GigabitEthernet0/0/1]quit

[R2]interface LoopBack 0 // Create the loopback port number as 0

[R2-LoopBack0]ip address 8.8.8.8 32 // Configure IP address

[R2-LoopBack0]quit

【Technical points】

Loopback is a logical interface inside the router. A logical interface refers to an interface that can realize the data exchange function, but does not exist physically and needs to be established through configuration. Once a loopback interface is created, its physical status and link protocol status are always Up, even if no IP address is configured on the interface. It is because of this characteristic that the Loopback interface has a special purpose. In this experiment, 8.8.8.8 in loopback is equivalent to a server on the public network.

(2) Floating static routes

If the experiment requires: R1 accesses the data of 8.8.8.8 through the g0/0/0 port, and only when there is a problem with the link of g0/0/0 will it go out through the g0/0/1 port, we can use the floating Static routing to configure, the configuration is as follows:

[R1]ip route-static 8.8.8.8 255.255.255.255 12.1.1.2 preference 50  //

[R1]ip route-static 8.8.8.8 255.255.255.255 10.1.1.2 preference 100

【Technical points】

  Preference represents the degree of trustworthiness of a route, the smaller the better.

  1. Experimental debugging

      (1) View the routing table of R1

 <R1>display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 7        Routes : 7       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        8.8.8.8/32  Static  50   0          RD   12.1.1.2        GigabitEthernet0/0/0

  From the above output, we can see that there is only one static route to 8.8.8.8 in the routing table.

(2) Check the detailed information of this route in 8.8.8.8

<R1>display ip routing-table 8.8.8.8 verbose

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Table : Public

Summary Count : 2

Destination: 8.8.8.8/32

     Protocol: Static          Process ID: 0

   Preference: 50                    Cost: 0

      NextHop: 12.1.1.2         Neighbour: 0.0.0.0

        State: Active Adv Relied      Age: 00h12m54s

          Tag: 0                 Priority: medium

        Label: NULL               QoSInfo: 0x0

   IndirectID: 0x80000001       

 RelayNextHop: 0.0.0.0          Interface: GigabitEthernet0/0/0

     TunnelID: 0x0 Flags: RD

Destination: 8.8.8.8/32

     Protocol: Static          Process ID: 0

   Preference: 100                   Cost: 0

      NextHop: 10.1.1.2         Neighbour: 0.0.0.0

        State: Inactive Adv Relied    Age: 00h12m41s

          Tag: 0                 Priority: medium

        Label: NULL               QoSInfo: 0x0

   IndirectID: 0x80000002      

 RelayNextHop: 0.0.0.0          Interface: GigabitEthernet0/0/1

     TunnelID: 0x0 Flags: R

Through the above output, you can see that there are two routes, the route with the next hop of 12.1.1.2 has a priority of 50, the route with the next hop of 10.1.1.2 has a priority of 100, and the route with a priority of 50 has been placed in the routing table , priority 100 is not selected.

(3) Close the g0/0/0 interface, causing the link failure of the g0/0/0 interface

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]shutdown

[R1-GigabitEthernet0/0/0]quit

(4) View the routing table of R1

[R1]display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 5        Routes : 5       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        8.8.8.8/32  Static  100  0          RD   10.1.1.2        GigabitEthernet0/0/1

Through the above output, you can see that the route with priority 100 appears in the routing table, which is the floating static route

(5) Open the g0/0/0 interface of R1

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]undo shutdown

[R1-GigabitEthernet0/0/0]quit

(6) View the routing table of R1

[R1]display ip routing-table

Route Flags: R - relay, D - download to fib

------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 7        Routes : 7       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        8.8.8.8/32  Static  50   0          RD   12.1.1.2        GigabitEthernet0/0/0

From the above output, we can see that the route with priority 50 has returned to the routing table.

4.4 Summary of Static Routing Commands

Table 4-2 lists the commands used in this chapter

                                                 Table 4-2 Summary of static routing commands

Order

effect

ip route-static

Configure static routing

display ip routing-table

View the global routing table

display  ip routing-table x.x.x.x verbose

View details of a route entry

Jingdong link:

"2023 Huawei HCIA-Datacom Certification Experiment Guide hcia Datacom Textbook Study Guide Huawei ICT Datacom Certification Network Engineering Examiner Self-study Textbook Computer Network Examination Certification Experiment Guide Communication Network Operation and Maintenance Technology Course" (Wang Jin, Liu Wei) [Abstract Book Review Trial Reading 】- Jingdong Books Jingdong JD.COM book channel provides you with "2023 Huawei HCIA-Datacom Certification Experiment Guide hcia datacom Textbook Study Guide Huawei ICT Datacom Certification Network Engineering Examiner Self-study Textbook Computer Network Examination Certification Experiment Guide Communication Network Operation and Maintenance Technology Tutorial "Online purchase, the author of this book: , Publisher: China Water Conservancy and Hydropower Publishing House. buy books, go Kyoto. Buy books online and enjoy the lowest discount! icon-default.png?t=N3I4https://item.jd.com/13337841.html

This article is from the author's "Huawei Certification HCIA-datacom Certification Experiment Guide"

 

Guess you like

Origin blog.csdn.net/lwljh134/article/details/130258683