Huawei switch telnet remote configuration method (only password authentication and AAA authentication)

Topology

  1. password authentication only

LSW1 configuration:

<Huawei>system-view -----Enter configuration mode

[Huawei]vlan 10 ----- create vlan10

[Huawei]interface vlan 10 ----- enter management vlan 10

[Huawei-Vlanif10]ip address 192.168.10.1 255.255.255.0 ----- configure management ip address

[Huawei-Vlanif10] quit ----- quit

[Huawei] interface GigabitEthernet 0/0/1 -----Enter port mode

[Huawei] port link-type trunk----change the port type to trunk

[Huawei] port trunk allow-pass vlan 10-----The trunk port allows vlan 10 to pass

[Huawei]telnet server enable -----Enable the telnet service (usually enabled by default)

[Huawei]user-interface vty 0 4 -----User-specified virtual user terminal interface

[Huawei-ui-vty0-4]authentication-mode password -----Configure user terminal interface authentication mode password authentication

[Huawei-ui-vty0-4]set authentication password cipher 123.com -----Set the interface authentication password, the password is 123.com

[Huawei-ui-vty0-4]user privilege level 15 -----Set user priority

[Huawei-ui-vty0-4]idle-timeout 5-----Set the login timeout to five minutes (optional)

<Huawei>save -----save

LSW2 configuration:

<Huawei>system-view -----Enter configuration mode

[Huawei]vlan 10 ----- create vlan10

[Huawei]interface vlan 10 ----- enter management vlan 10

[Huawei-Vlanif10]ip address 192.168.10.2 255.255.255.0 ----- configure management ip address

[Huawei-Vlanif10] quit ----- quit

[Huawei] interface GigabitEthernet 0/0/1 -----Enter port mode

[Huawei] port link-type trunk----change the port type to trunk

[Huawei] port trunk allow-pass vlan 10-----The trunk port allows vlan 10 to pass

[Huawei]telnet server enable -----Enable the telnet service (usually enabled by default)

[Huawei]user-interface vty 0 4 -----User-specified virtual user terminal interface

[Huawei-ui-vty0-4]authentication-mode password -----Configure user terminal interface authentication mode password authentication

[Huawei-ui-vty0-4]set authentication password cipher 123.com -----Set the interface authentication password, the password is 123.com

[Huawei-ui-vty0-4]user privilege level 15 -----Set user priority

[Huawei-ui-vty0-4]idle-timeout 5-----Set the login timeout to five minutes (optional)

<Huawei>save -----save

test

  1. AAA authentication

LSW1 configuration:

<Huawei>system-view -----Enter configuration mode

[Huawei]vlan 10 ----- create vlan10

[Huawei]interface vlan 10 ----- enter management vlan 10

[Huawei-Vlanif1]ip address 192.168.10.1 255.255.255.0 ----- configure management ip address

[Huawei-Vlanif1] quit ----- quit

[Huawei] interface GigabitEthernet 0/0/1 -----Enter port mode

[Huawei] port link-type trunk----change the port type to trunk

[Huawei] port trunk allow-pass vlan 10-----The trunk port allows vlan 10 to pass

[Huawei]telnet server enable -----Enable the telnet service (usually enabled by default)

[Huawei]user-interface vty 0 4 -----User-specified virtual user terminal interface

[Huawei-ui-vty0-4]authentication-mode aaa -----Configure the user terminal interface authentication mode aaa authentication

[Huawei-ui-vty0-4]user privilege level 15 -----Set user priority

[Huawei-ui-vty0-4]idle-timeout 5 -----Set the login timeout to five minutes

[Huawei-ui-vty0-4] quit ----- quit

[Huawei]aaa -----Introductionaaa

[Huawei-aaa]local-user admin password cipher 123.com-----create username admin password cipher 123.com

[Huawei-aaa]local-user admin privilege level 15 -----Set user priority

[Huawei-aaa]local-user admin service-type telnet -----Authorize users to use telnet

<Huawei>save -----save

LSW2 configuration:

<Huawei>system-view -----Enter configuration mode

[Huawei]vlan 10 ----- create vlan10

[Huawei]interface vlan 10 ----- enter management vlan 10

[Huawei-Vlanif1]ip address 192.168.10.2 255.255.255.0 ----- configure management ip address

[Huawei-Vlanif1] quit ----- quit

[Huawei] interface GigabitEthernet 0/0/1 -----Enter port mode

[Huawei] port link-type trunk----change the port type to trunk

[Huawei] port trunk allow-pass vlan 10-----The trunk port allows vlan 10 to pass

[Huawei]telnet server enable -----Enable the telnet service (usually enabled by default)

[Huawei]user-interface vty 0 4 -----User-specified virtual user terminal interface

[Huawei-ui-vty0-4]authentication-mode aaa -----Configure the user terminal interface authentication mode aaa authentication

[Huawei-ui-vty0-4]user privilege level 15 -----Set user priority

[Huawei-ui-vty0-4]idle-timeout 5 -----Set the login timeout to five minutes

[Huawei-ui-vty0-4] quit ----- quit

[Huawei]aaa -----Introductionaaa

[Huawei-aaa]local-user admin password cipher 123.com-----create username admin password cipher 123.com

[Huawei-aaa]local-user admin privilege level 15 -----Set user priority

[Huawei-aaa]local-user admin service-type telnet -----Authorize users to use telnet

<Huawei>save -----save

test

Guess you like

Origin blog.csdn.net/qq_42966610/article/details/129922984