H3C-Ethernet Link Aggregation

1.8.1  Example of Layer 2 Static Aggregation Configuration

1. Networking requirements

· Device A and Device B are connected to each other through their respective Layer 2 Ethernet interfaces GigabitEthernet4/0/1 to GigabitEthernet4/0/3.

· Configure Layer 2 static link aggregation groups on Device A and Device B respectively, and implement communication between VLAN 10 and VLAN 20 between the devices.

2. Network diagram

Figure 1-4 Network diagram for Layer 2 static aggregation configuration

 3. Configuration steps

(1) Configure Device A

# Create VLAN 10 and add port GigabitEthernet4/0/4 to this VLAN.

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port GigabitEthernet 4/0/4

[DeviceA-vlan10] quit

# Create VLAN 20 and add port GigabitEthernet4/0/5 to this VLAN.

[DeviceA] vlan 20

[DeviceA-vlan20] port GigabitEthernet 4/0/5

[DeviceA-vlan20] quit

# Create Layer 2 aggregation interface 1.

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] quit

# Add ports GigabitEthernet4/0/1 to GigabitEthernet4/0/3 to aggregation group 1 respectively.

[DeviceA] interface GigabitEthernet 4/0/1

[DeviceA-GigabitEthernet4/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/1] quit

[DeviceA] interface GigabitEthernet 4/0/2

[DeviceA-GigabitEthernet4/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/2] quit

[DeviceA] interface GigabitEthernet 4/0/3

[DeviceA-GigabitEthernet4/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/3] quit

# Configure Layer 2 aggregation interface 1 as a trunk port and allow packets of VLANs 10 and 20 to pass through.

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20

[DeviceA-Bridge-Aggregation1] quit

(2) Configure Device B

The configuration of Device B is similar to that of Device A, and the configuration process is omitted here.

4. Verify configuration

# Display detailed information about all aggregation groups on Device A.

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 Aggregate Interface: Bridge-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

  Port             Status  Priority Oper-Key

--------------------------------------------------------------------------------

  GE4/0/1          S       32768    1

  GE4/0/2          S       32768    1

  GE4/0/3          S       32768    1

The above information shows that aggregation group 1 is a Layer 2 static aggregation group of load balancing type and contains three selected ports.

1.8.2  Configuration Example of Layer 2 Dynamic Aggregation

1. Networking requirements

· Device A and Device B are connected to each other through their respective Layer 2 Ethernet interfaces GigabitEthernet4/0/1 to GigabitEthernet4/0/3.

· Configure Layer 2 dynamic link aggregation groups on Device A and Device B respectively, and implement communication between VLAN 10 and VLAN 20 between the devices.

2. Network diagram

Figure 1-5 Layer 2 dynamic aggregation configuration network diagram

 

3. Configuration steps

(1) Configure Device A

# Create VLAN 10 and add port GigabitEthernet4/0/4 to this VLAN.

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port GigabitEthernet 4/0/4

[DeviceA-vlan10] quit

# Create VLAN 20 and add port GigabitEthernet4/0/5 to this VLAN.

[DeviceA] vlan 20

[DeviceA-vlan20] port GigabitEthernet 4/0/5

[DeviceA-vlan20] quit

# Create Layer 2 aggregation interface 1 and configure the interface to be in dynamic aggregation mode.

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation1] quit

# Add ports GigabitEthernet4/0/1 to GigabitEthernet4/0/3 to aggregation group 1 respectively.

[DeviceA] interface GigabitEthernet 4/0/1

[DeviceA-GigabitEthernet4/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/1] quit

[DeviceA] interface GigabitEthernet 4/0/2

[DeviceA-GigabitEthernet4/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/2] quit

[DeviceA] interface GigabitEthernet 4/0/3

[DeviceA-GigabitEthernet4/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet4/0/3] quit

# Configure Layer 2 aggregation interface 1 as a trunk port and allow packets of VLANs 10 and 20 to pass through.

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20

[DeviceA-Bridge-Aggregation1] quit

(2) Configure Device B

The configuration of Device B is similar to that of Device A, and the configuration process is omitted here.

4. Verify configuration

# Display detailed information about all aggregation groups on Device A.

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 Aggregate Interface: Bridge-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

System ID: 0x8000, 000f-e267-6c6a

Local:

  Port             Status  Priority Oper-Key  Flag

--------------------------------------------------------------------------------

  GE4/0/1          S       32768    1         {ACDEF}

  GE4/0/2          S       32768    1         {ACDEF}

  GE4/0/3          S       32768    1         {ACDEF}

Remote:

  Actor            Partner Priority Oper-Key  SystemID               Flag

--------------------------------------------------------------------------------

  GE4/0/1          1       32768    1         0x8000, 000f-e267-57ad {ACDEF}

  GE4/0/2          2       32768    1         0x8000, 000f-e267-57ad {ACDEF}

  GE4/0/3          3       32768    1         0x8000, 000f-e267-57ad {ACDEF}

The above information shows that aggregation group 1 is a Layer 2 dynamic aggregation group of load balancing type, and includes three selected ports.

1.8.3  Layer 3 Static Aggregation Configuration Example

1. Networking requirements

· Device A and Device B are connected to each other through their respective Layer 3 Ethernet interfaces GigabitEthernet3/0/1 to GigabitEthernet3/0/3.

· Configure Layer 3 static link aggregation groups on Device A and Device B respectively, and configure IP addresses and subnet masks for the corresponding Layer 3 aggregation interfaces.

2. Network diagram

Figure 1-6 Network diagram for Layer 3 static aggregation configuration

 3. Configuration steps

(1) Configure Device A

# Create Layer 3 aggregation interface 1, and configure an IP address and subnet mask for the interface.

<DeviceA> system-view

[DeviceA] interface route-aggregation 1

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] quit

# Add interfaces GigabitEthernet3/0/1 to GigabitEthernet3/0/3 to aggregation group 1 respectively.

[DeviceA] interface GigabitEthernet 3/0/1

[DeviceA-GigabitEthernet3/0/1] port link-mode route

[DeviceA-GigabitEthernet3/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/1] quit

[DeviceA] interface GigabitEthernet 3/0/2

[DeviceA-GigabitEthernet3/0/2] port link-mode route

[DeviceA-GigabitEthernet3/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/2] quit

[DeviceA] interface GigabitEthernet 3/0/3

[DeviceA-GigabitEthernet3/0/3] port link-mode route

[DeviceA-GigabitEthernet3/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/3] quit

(2) Configure Device B

The configuration of Device B is similar to that of Device A, and the configuration process is omitted here.

4. Verify configuration

# Display detailed information about all aggregation groups on Device A.

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 Aggregate Interface: Route-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

  Port             Status  Priority Oper-Key

--------------------------------------------------------------------------------

  GE3/0/1 S32768 1

  GE3/0/2 S 32768 1

  GE3/0/3 S 32768 1

The above information shows that aggregation group 1 is a three-layer static aggregation group of load balancing type, and includes three selected ports.

1.8.4  Layer 3 Dynamic Aggregation Configuration Example

1. Networking requirements

· Device A and Device B are connected to each other through their respective Layer 3 Ethernet interfaces GigabitEthernet3/0/1 to GigabitEthernet3/0/3.

· Configure Layer 3 dynamic link aggregation groups on Device A and Device B respectively, and configure IP addresses and subnet masks for the corresponding Layer 3 aggregation interfaces.

2. Network diagram

Figure 1-7 Layer 3 dynamic aggregation configuration network diagram

 

3. Configuration steps

(1) Configure Device A

# Create Layer 3 aggregation interface 1, configure the interface to be in dynamic aggregation mode, and configure an IP address and subnet mask for it.

<DeviceA> system-view

[DeviceA] interface route-aggregation 1

[DeviceA-Route-Aggregation1] link-aggregation mode dynamic

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] quit

# Add interfaces GigabitEthernet3/0/1 to GigabitEthernet3/0/3 to aggregation group 1 respectively.

[DeviceA] interface GigabitEthernet 3/0/1

[DeviceA-GigabitEthernet3/0/1] port link-mode route

[DeviceA-GigabitEthernet3/0/1] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/1] quit

[DeviceA] interface GigabitEthernet 3/0/2

[DeviceA-GigabitEthernet3/0/2] port link-mode route

[DeviceA-GigabitEthernet3/0/2] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/2] quit

[DeviceA] interface GigabitEthernet 3/0/3

[DeviceA-GigabitEthernet3/0/3] port link-mode route

[DeviceA-GigabitEthernet3/0/3] port link-aggregation group 1

[DeviceA-GigabitEthernet3/0/3] quit

(2) Configure Device B

The configuration of Device B is similar to that of Device A, and the configuration process is omitted here.

4. Verify configuration

# Display detailed information about all aggregation groups on Device A.

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

Aggregate Interface: Route-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

System ID: 0x8000, 000f-e267-6c6a

Local:

  Port             Status  Priority Oper-Key  Flag

--------------------------------------------------------------------------------

  GE3/0/1 S 32768 1 {ACDEF}

  GE3/0/2 S 32768 1 {ACDEF}

  GE3/0/3 S 32768 1 {ACDEF}

Remote:

  Actor            Partner Priority Oper-Key  SystemID               Flag

--------------------------------------------------------------------------------

  GE3/0/1 1 32768 1 0x8000, 000f-e267-57ad {ACDEF}

  GE3/0/2 2 32768 1 0x8000, 000f-e267-57ad {ACDEF}

  GE3/0/3 3 32768 1 0x8000, 000f-e267-57ad {ACDEF}

The above information shows that Aggregation Group 1 is a Layer 3 dynamic aggregation group of load balancing type and contains three selected ports.

1.8.5  Configuration Example of Layer 2 Aggregation Edge Interface

1. Networking requirements

·               Device and server are connected to each other through ports GigabitEthernet1/0/1 and GigabitEthernet1/0/2.

·               Configure a Layer 2 dynamic link aggregation group on Device and Server respectively.

·               Configure the Layer 2 aggregation interface on the Device as an aggregation edge interface so that the aggregation group member ports can forward packets normally when the server restarts.

2. Network diagram

Figure 1-8 Network diagram for configuring Layer 2 aggregation edge interfaces

 

3. Configuration steps

(1)       Configure Device

#Create Layer 2 aggregation interface 1, and configure the interface to be in dynamic aggregation mode.

<Device> system-view

[Device] interface bridge-aggregation 1

[Device-Bridge-Aggregation1] link-aggregation mode dynamic

#Configure Layer 2 aggregation interface 1 as the aggregation edge interface.

[Device-Bridge-Aggregation1] lacp edge-port

[Device-Bridge-Aggregation1] quit

#Add ports GigabitEthernet1/0/1 and GigabitEthernet1/0/2 to aggregation group 1 respectively.

[Device] interface gigabitethernet 1/0/1

[Device-GigabitEthernet1/0/1] port link-aggregation group 1

[Device-GigabitEthernet1/0/1] quit

[Device] interface gigabitethernet 1/0/2

[Device-GigabitEthernet1/0/2] port link-aggregation group 1

[Device-GigabitEthernet1/0/2] quit

(2)       Configure Server

Configure the Server according to the networking requirements , and the specific configuration process is omitted.

4. Verify configuration

#During the server restart process, view the detailed information of all aggregation groups on the Device.

[Device] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

Aggregate Interface: Bridge-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

System ID: 0x8000, 000f-e267-6c6a

Local:

  Port             Status  Priority Oper-Key  Flag

--------------------------------------------------------------------------------

  GE1/0/1          I       32768    1         {AG}

  GE1/0/2          I       32768    1         {AG}

Remote:

  Actor            Partner Priority Oper-Key  SystemID               Flag

--------------------------------------------------------------------------------

  GE1/0/1          0       32768    0         0x8000, 0000-0000-0000 {EF}

  GE1/0/2          0       32768    0         0x8000, 0000-0000-0000 {EF}

The above information shows that when the Device does not receive the LACP packet from the Server, the aggregation member ports of the Device work in the Individual state. In this state, the aggregation member ports can be used as ordinary physical ports to forward packets to ensure that the Server sends packets are not discarded.

1.8.6  Layer 3 Aggregation Edge Interface Configuration Example

1. Networking requirements

·               Device and server are connected to each other through GigabitEthernet1/0/1 and GigabitEthernet1/0/2.

·               Configure a Layer 3 dynamic link aggregation group on Device and Server respectively, and configure IP address and subnet mask.

·               Configure the Layer 3 dynamic link aggregation interface on the device as the aggregation edge interface so that the member ports of the aggregation group can forward packets normally when the server is restarted.

2. Network diagram

Figure 1-9 Layer 3 aggregation edge interface configuration network diagram

 

3. Configuration steps

(1)       Configure Device

#Create Layer 3 aggregation interface 1, configure the interface as dynamic aggregation mode, and configure an IP address and subnet mask for it.

<Device> system-view

[Device] interface route-aggregation 1

[Device-Route-Aggregation1] link-aggregation mode dynamic

[Device-Route-Aggregation1] ip address 192.168.1.1 24

#Configure Layer 3 aggregation interface 1 as the aggregation edge interface.

[Device-Route-Aggregation1] lacp edge-port

[Device-Route-Aggregation1] quit

#Add ports GigabitEthernet1/0/1 and GigabitEthernet1/0/2 to aggregation group 1 respectively.

[Device] interface gigabitethernet 1/0/1

[Device-GigabitEthernet1/0/1] port link-mode route

[Device-GigabitEthernet1/0/1] port link-aggregation group 1

[Device-GigabitEthernet1/0/1] quit

[Device] interface gigabitethernet 1/0/2

[Device-GigabitEthernet1/0/2] port link-mode route

[Device-GigabitEthernet1/0/2] port link-aggregation group 1

[Device-GigabitEthernet1/0/2] quit

(2)       Configure Server

Configure the Server according to the networking requirements , and the specific configuration process is omitted.

4. Verify configuration

#During the server restart process, view the detailed information of all aggregation groups on the Device.

[Device] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

Aggregate Interface: Route-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

System ID: 0x8000, 000f-e267-6c6a

Local:

  Port             Status  Priority Oper-Key  Flag

--------------------------------------------------------------------------------

  GE1/0/1          I       32768    1         {AG}

  GE1/0/2          I       32768    1         {AG}

Remote:

  Actor            Partner Priority Oper-Key  SystemID               Flag

--------------------------------------------------------------------------------

  GE1/0/1          0       32768    0         0x8000, 0000-0000-0000 {EF}

  GE1/0/2          0       32768    0         0x8000, 0000-0000-0000 {EF}

The above information shows that when the Device does not receive the LACP packet from the Server, the aggregation member ports of the Device work in the Individual state. In this state, the aggregation member ports can be used as ordinary physical ports to forward packets to ensure that the Server sends packets are not discarded.

Guess you like

Origin blog.csdn.net/qq_42966610/article/details/130153715