wlan configuration - thin AP configuration [simple topology, detailed code, command explanation]

topology

insert image description here

configuration

LSW2 configuration

Layer 2 switching, it doesn’t matter if it doesn’t match.

vlan 10
int e0/0/1
port link-type trunk
port trunk allow-pass vlan 10

int e0/0/2
port link-type access
port default vlan 10

int e0/0/2
port link-type access
port default vlan 10

LSW1 configuration

vlan batch 10 30

int vlan 10
ip add 192.168.1.254 24

int vlan 30
ip add 1.1.1.2 24

int g0/0/1
port link-type trunk
port trunk allow-pass vlan 10

int g0/0/2
port link-type trunk
port trunk allow-pass vlan all

dhcp enable

ip pool forap
gateway-list 192.168.1.254
network 192.168.1.0 mask 255.255.255.0
option 43 sub-option 2 ip-address 1.1.1.1
The above sentence is the key point.

interface Vlanif 10
dhcp select global
Layer 3 switching should call the global address pool in vlanif.

AC1 configuration

1. Wired configuration

vlan 30

int vlan 30
ip add 1.1.1.1 24

ip route-static 192.168.1.0 24 1.1.1.2

int g0/0/1
port link-type trunk
port trunk allow-pass vlan all

2. Template configuration

wlan

Administrative template configuration

[AC6005-wlan-view]regulatory-domain-profile name dom
Command Explanation:
Create a regulatory profile named dom.
[AC6005-wlan-regulate-domain-dom]country-code cn
command explanation:
set the country code to cn, China is cn.
Info: The current country code is same with the input country code.
[AC6005-wlan-regulate-domain-dom]q

ssid template configuration

This template will be referenced to 4G RF, if you don’t understand it, it’s okay to read it slowly.
[AC6005-wlan-view] ssid-profile name ssid-cfg-1
Command Explanation:
Create an ssid profile named ssid-cfg-1.
[AC6005-wlan-ssid-prof-ssid-cfg-2] ssid wifi-2.4GHz
command explanation:
Name the ssid as wifi-2.4GHz, which is the name of WiFi.
Info: This operation may take a few seconds, please wait. done.
[AC6005-wlan-ssid-prof-ssid-cfg-2]q

This template will be referenced to 5G radios.
[AC6005-wlan-view]ssid-profile name ssid-cfg-2
[AC6005-wlan-ssid-prof-ssid-cfg-2]ssid wifi-5GHz
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-ssid-prof-ssid-cfg-2]q

Security template configuration

[AC6005-wlan-view]security-profile name sec
Command Explanation:
Create a security profile named sec.
[AC6005-wlan-sec-prof-sec]security wpa-wpa2 psk pass-phrase a1234567 aes
command explanation:
Configure the security policy of wpa-wpa2 psk, the password is a1234567, and the password encryption method is aes.
[AC6005-wlan-sec- prof-sec]q

VAP profile configuration

[AC6005-wlan-view]vap-profile name vap-cfg-1
Command Explanation:
Create a VAP profile named vap-cfg-1.
[AC6005-wlan-vap-prof-vap-cfg-1] forward-mode direct-forward
Command Explanation:
Set the forwarding mode of the AP to direct forwarding.
[AC6005-wlan-vap-prof-vap-cfg-1] security-profile sec
Command Explanation:
The security profile named sec is referenced.
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-vap-prof-vap-cfg-1] ssid-profile ssid-cfg-1
command explanation:
refer to the ssid-cfg-1 ssid template, refer to this template wireless signal will be displayed as wifi-2.4GHz, understand the above ssid template is not wow.
Info: This operation may take a few seconds, please wait. done.
[AC6005-wlan-vap-prof-vap-cfg-1]q

[AC6005-wlan-view]vap-profile name vap-cfg-2
[AC6005-wlan-vap-prof-vap-cfg-2]forward-mode direct-forward
[AC6005-wlan-vap-prof-vap-cfg-2]security-profile sec
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-vap-prof-vap-cfg-2]ssid-profile ssid-cfg-2
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-vap-prof-vap-cfg-2]q

AP group configuration

[AC6005-wlan-view]ap-group name ap-g
Command Explanation:
Create an AP group named ap-g.
This command is also used to enter the AP group named ap-g.
[AC6005-wlan-ap-group-ap-g]regulatory-domain-profile dom
Command Explanation:
The administrative profile named dom is referenced and needs to be created in advance.
Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continue?[Y/N]:y [
AC6005-wlan-ap-group-ap-g]vap-profile vap- cfg-1 wlan 1 radio 0
command explanation:
In wlan number 1, radio frequency number 0 refers to the VAP profile named vap-cfg-1.
The radio frequency numbered 0 is 4G.
Info: This operation may take a few seconds, please wait…done.
[AC6005-wlan-ap-group-ap-g]vap-profile vap-cfg-2 wlan 1 radio 1 command
explanation:
in wlan numbered 1 , the radio frequency numbered 1 refers to the VAP profile named vap-cfg-2.
The radio frequency numbered 1 is 5G.
Info: This operation may take a few seconds, please wait…done.

3. AP goes online

Selected authentication method

[AC6005-wlan-view]ap auth-mode mac-auth
command explanation: The authentication mode of the ap is mac-auth, that is, mac address authentication.

AP1 is online

[AC6005-wlan-view]ap-id 1 ap-mac 00e0-fc07-0840
Command Explanation: The AP whose hardware address is 00e0-fc07-0840 goes online, and the number is 1
[AC6005-wlan-ap-1]ap-group ap -g
command explanation: Add the AP numbered 1 to the AP group named ap-g
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configurations of the radio, Whether to continue? [Y/N]:y
Info: This operation may take a few seconds. Please wait for a moment… done.

AP2 is online

[AC6005-wlan-view]ap-id 2 ap-mac 00e0-fc55-7750
[AC6005-wlan-ap-2]ap-group ap-g
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configurations of the radio, Whether to continue? [Y/N]:y
Info: This operation may take a few seconds. Please wait for a moment… done.
[AC6005-wlan-ap-2]q
[AC6005-wlan-view]q

capwap command

[AC6005]capwap source interface vlanif 30

Note: This command is not configured in WLAN view.

detection

If there are two big circles, it means OK.
insert image description here
If you still don’t understand the ssid template, you can see the picture below.
insert image description here

Summarize

First of all: the capwap command is easy to miss.
Secondly: When configuring the dhcp address pool, the sentence of option 43 is easy to miss.
Again: You must first configure option 43 and then dhcp select global. You can’t find that there is no option 43 after dhcp select global, and then configure option 43. Do you know why? Because the assigned dhcp address and the things in the address pool have already taken effect and are still within the lease period, the things in the address pool without option 43 are used.

Finally: These are all switches, please go to vlaif for IP address allocation, and the same for dhcp select global.

If there is something to gain, hey, give it a thumbs up!

Guess you like

Origin blog.csdn.net/qq_48330132/article/details/128350251