Nim POJ - 2975 (Boutons Theorem + Games)

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input
3
7 11 13
2
1000000000 1000000000
0
Sample Output
3
0

Title :

There are n piles of stones, two people A and B take turns to take, and each time they take at least one stone from a certain pile. If there is no stone to take when it is someone's turn, that person loses.

When A has a sure-win strategy, it does not mean that he can win by choosing stones from any pile, but that A must win by taking a certain number of stones from a certain pile. Find the number of ways that A can choose.

1, first calculate the value of all XOR, res ^= a[i];

2, res and each value XOR, if less than the value ans++ , res ^a[i] < a[i];

To XOR the value to zero, the number we take will be XORed with res to be 0. If res ^ a[i] >= a[i] , then this number cannot be XORed by taking a value. It becomes larger than it was, so this case is ignored.

Note: XOR has lower precedence than relational operators

code below

#include <stdio.h>
#include <iostream>
#include <cstring>
using namespace std;
intmain()
{
	long long int n , ans , res , a[1005];
	while(~scanf("%lld" , &n) && n)
	{
		res = 0 ;
		years = 0;
		for(int i = 0 ; i < n ; i++)
		{
			scanf("%lld" , &a[i]);
			res ^= a[i];
		}
		for(int i = 0 ; i < n ; i++)
		{
			if((res ^ a[i] ) < a[i])
			{
				years++;
			}
		}
		printf("%lld\n" , ans);
	}
	return 0;
}


Guess you like

Origin http://10.200.1.11:23101/article/api/json?id=326711361&siteId=291194637