AtCoder Beginner Contest 096 D - Five, Five Everywhere



Problem Statement

Print a sequence a1,a2,…,aN whose length is N that satisfies the following conditions:

  • to i (1iN) is a prime number at most 55 555.
  • The values of a1,a2,…,aN are all different.
  • In every choice of five different integers from a1,a2,…,aN, the sum of those integers is a composite number.

If there are multiple such sequences, printing any of them is accepted.

Notes

An integer N not less than 2 is called a prime number if it cannot be divided evenly by any integers except 1 and N, and called a composite number otherwise.

Constraints

  • N is an integer between 5 and 55 (inclusive).

Input

Input is given from Standard Input in the following format:

N

Output

Print N numbers a1,a2,a3,…,aN in a line, with spaces in between.


Sample Input 1

Copy
5

Sample Output 1

Copy
3 5 7 11 31

Let us see if this output actually satisfies the conditions.
First, 3, 5, 7, 11 and 31 are all different, and all of them are prime numbers.
The only way to choose five among them is to choose all of them, whose sum is a1+a 2+and 3+a 4+a 5=57, which is a composite number.
There are also other possible outputs, such as 2 3 5 7 13, 11 13 17 19 31 and 7 11 5 31 3.


Sample Input 2

Copy
6

Sample Output 2

Copy
2 3 5 7 11 13
  • 2, 3, 5, 7, 11, 13 are all different prime numbers.
  • 2+3+5+7+11=28 is a composite number.
  • 2+3+5+7+13=30 is a composite number.
  • 2+3+5+11+13=34 is a composite number.
  • 2+3+7+11+13=36 is a composite number.
  • 2+5+7+11+13=38 is a composite number.
  • 3+5+7+11+13=39 is a composite number.

Thus, the sequence 2 3 5 7 11 13 satisfies the conditions.


Sample Input 3

Copy
8

Sample Output 3

Copy
2 5 7 13 19 37 67 79

The meaning of the question: Given a sequence of prime numbers of length n, the sum of 5 numbers randomly drawn from it is composite, and the sequence is calculated.

Idea: Because the sum of 5 prime numbers is a composite number, as long as the digit in the 5 numbers is the same

#include <bits/stdc++.h>
using namespace std;
int num[20000];
int pr[100];

int is_prime(int n)
{
    int m=sqrt(n+0.5);
    for(int i=2; i<=m; i++)
        if(n%i==0)
            return 0;
    return 1;
}

intmain()
{
    int cnt=0;
    for (int i = 3; i <55555; i ++) // Judgment prime number
        if(is_prime(i))
            num[cnt++]=i;
    int k=0;
    for(int i=0; i<cnt; i++) //record bits
    {
        if((num[i]-1)%5==0)
            pr[k++]=num[i];
        if(k==60)
            break;
    }
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        if(i!=0)
            cout << ' ';
        cout << pr[i];
    }
    cout << endl;
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325705618&siteId=291194637