swustoj1132Coin-collecting by robot

Several coins are placed in cells of an n×m board. A robot, located in the upper left cell of the board, needs to collect as many of the coins as possible and bring them to the bottom right cell. On each step, the robot can move either one cell to the right or one cell down from its current location.

enter

The fist line is n,m, which 1< = n,m <= 1000.
Then, have n row and m col, which has a coin in cell, the cell number is 1, otherwise is 0.

output

The max number Coin-collecting by robot.

sample input

5 6
0 0 0 0 1 0
0 1 0 1 0 0
0 0 0 1 0 1
0 0 1 0 0 1
1 0 0 0 1 0

Sample output

5

The idea: dynamic programming.

dp[i][j] represents the maximum number of coins that can be obtained by walking to the point (i, j).

The transfer equation is:

mp [i] [j] = max (mp [i -1] [j], mp [i] [j -1]);



#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
#include<string.h>
using namespace std;
int mp[1005][1005];
//oj1132
intmain()
{
	int n, m;
	while (cin >> n >> m) {
		for (int i = 0;i < n;i++) {
			for (int j = 0;j < m;j++) {
				scanf("%d", &mp[i][j]);
			}
		}
		for (int i = 1;i < n;i++)
		 {
			if (mp[i][0] == 1) {
				mp [i] [0] = mp [i -1] [0] +1;
			}
			else {
				mp [i] [0] = mp [i -1] [0];
			}
		}
		 for (int i = 1;i < m;i++) {
			 if (mp[0][i] == 1) {
				 mp [0] [i] = mp [0] [i -1] + 1;
			 }
			 else {
				 mp [0] [i] = mp [0] [i -1];
			 }
		 }
		for (int i = 1;i < n;i++) {
			for (int j = 1;j < m;j++) {
				if(mp[i][j])
				mp [i] [j] = max (mp [i -1] [j], mp [i] [j -1]) +1;
				else {
					mp [i] [j] = max (mp [i -1] [j], mp [i] [j -1]);
				}
			}
		}
		int ans = mp[n - 1][m - 1];
		cout <<  ans <<"\r\n";
	}
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325668816&siteId=291194637
Recommended