Cable master

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numbers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output

2.00 


This is a disgusting subject. In fact, it is very simple to give N things of different lengths, ask to cut out K short things with the same length, ask what is the maximum length of the K roots that meet the conditions, the minimum length is 0.01, if this condition cannot be satisfied, then output 0.00.

The function to judge whether the length mid can satisfy the condition, just use a[i]/mid and then add all i from 1 to N. a[i]/mid is of double type and needs to be converted into an integer. Here I use rounding down for easy understanding. In fact, the practical (int) coercion is not rounding. It is equivalent to floor here.

In the program, it is first judged whether 0.01 can cut out K roots, if not, there is no need to continue to judge.

Directly outputting .2lf is a rounding process, which will cause problems. For example, if the data is 3.766, if you printf directly, it will become 3.77. In this actual problem, it is obvious that the mantissa truncation method is used, and it can only be taken as large as possible. Take small. My approach is to round down the answer after *100, and then /100, to achieve the purpose of truncating three decimal places.

#include<iostream>
#include<cstdio>
#include<cmath>
#define INF 0x3f3f3f3f
#define ESP 1e-10
using namespace std;
double a[10003];
int N,K;
bool judge(double mid)
{
    double sum=0;
    for(int i=1;i<=N;i++)
    sum+=floor((a[i]/mid));
    //cout<<sum<<endl;
    return sum>=K;
}
intmain()
{
    cin>>N>>K;
    double mid;
    for(int i=1;i<=N;i++)
    {
        cin>>a[i];
    }
    if(!judge(0.01)) {cout<<"0.00"<<endl;return 0;}
    double lb=0.00,ub=INF;
    while(ub-lb>ESP)
    {
        mid=(ub+lb)/2;
        if(judge(mid)) lb=mid;
        else ub=mid;
        //cout<<lb<<' '<<ub<<endl;
    }
    ub=floor(ub*=100);//This hand is very critical. The data like 2.005 cannot be output directly. 2lf cannot be rounded but needs to be removed directly.
    ub/=100.;
    printf("%.2lf\n",ub);
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325474700&siteId=291194637