POJ-1064 Cable master

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00
The meaning of the question: Given N wooden sticks, it is required to cut out k segments of wooden sticks of equal length, and find the maximum equal length.

Ideas: It is obvious that the idea of ​​dichotomy, each mid, to see if it is satisfied, according to the number of segments cut out, divide the upper bound and the lower bound, the biggest pit point of this problem is the precision processing, of course, it can also be converted into integer solutions, here are mainly decimals practice,

AC code:

#include<iostream>
#include<queue>
#include<algorithm>
#include<stack>
#include<string>
#include<map>
#include<set>
#include<cstdio>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<cmath>
using namespace std;
const int MAX = 10010;
const int INF = 0X3f3f3f;
const double eps = 1e-8;

double cable[MAX];

int n, request;

int judge(double mid) {//判断当前mid 是否满足
    int sum = 0;
    for(int i = 0; i < n; i++) {
        sum += (int)(cable[i] / mid);//(int)转化
    }
    return sum >= request;// >= 返回1, <返回0
}

int main() {
    while(cin >> n >> request){//好像不用这样输入。
        for(int i = 0; i < n; i++) {
            scanf("%lf", &cable[i]);
        }
        double l = 0, r = 100001;
        double mid;
        while(r - l >= eps) {//注意这里是 >= 
            mid = (l + r) / 2;
            if(judge(mid)) {
                l = mid;
            }
            else
                r = mid;
        }// 结果就是r
        if((int)(r * 1000) % 10 >= 5) //本题最大坑点!!!结果不是保留2位小数,看小数点后第三位 是否 >= 5 
            r -= 0.005;//是的话,-0.005
        printf("%.2lf\n", r);
    }
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324474253&siteId=291194637