2178 Ordered collection of linked lists

Problem Description

  A set has an important property: mutuality, that is, any two elements in the set are different, and the mutuality makes the elements in the set not duplicate. Given n unordered positive integer sequences containing repeating numbers, create an ordered linked list, the nodes in the linked list are arranged in non-descending numerical order and do not contain repeating elements, and output the ordered linked list.

Input

The input contains multiple sets of test data, for each set of test data:
The first line of input is a positive integer n (1 ≤ n ≤ 100),
The second row is n positive integers b 1 , b 2 , . . . , b n (0 ≤ b i  ≤ 2 30 ).

Output

For each set of test data, output the node values ​​of the linked list in non-descending order.

Sample Input

1
2
2
1 1
6
6 3 5 2 2 3

Sample Output

2
1
2 3 5 6
import java.util. *;
public class Main
{
public static void main(String[] args)
{
Scanner sc = new Scanner(System.in);
while(sc.hasNext())
{
int i = sc.nextInt();
Set<Integer> a = new TreeSet<Integer>();
while(i--!=0)
{
a.add(sc.nextInt());
}
//Array.sort(a);
int m=0;
for(int j:a)
{
if(m==0)
System.out.print(j);
else
System.out.print(" "+j);
m++;
}
System.out.printf("\n");
//System.out.print(i);
}
sc.close();
}
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324788359&siteId=291194637