Java - Sorted Collection of Linked Lists

ordered collection of linked lists

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

  A set has an important property: mutuality, that is, any two elements in the set are different, and the mutuality makes the elements in the set not duplicate. Given n unordered positive integer sequences containing repeating numbers, create an ordered linked list, the nodes in the linked list are arranged in non-descending numerical order and do not contain repeating elements, and output the ordered linked list.

Input

The input contains multiple sets of test data, for each set of test data:
The first line of input is a positive integer n (1 ≤ n ≤ 100),
The second row is n positive integers b 1 , b 2 , . . . , b n (0 ≤ b i  ≤ 2 30 ).

Output

For each set of test data, output the node values ​​of the linked list in non-descending order.

Sample Input

1
2
2
1 1
6
6 3 5 2 2 3

Sample Output

2
1
2 3 5 6

Hint

 

import java.util. *;
import java.lang.*;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int t = sc.nextInt();
			long a[] =  new long[t];
			for(int i = 0; i < t; i++){
				a[i] = sc.nextLong();
			}
			Arrays.sort(a);
			System.out.print(a[0]);
			for(int i = 1; i < t; i++) {
				int flag = 0;
				for(int j = 0; j < i; j++) {
					if(a[i] == a[j]) {
						flag = 1;
						break;
					}
				}
				if(flag == 0) {
					System.out.print(" " + a[i]);
				}
			}
			System.out.println();
		}
		
		sc.close();
	}

}


或者(no

import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()) {
            int n = sc.nextInt();

            Set<Integer> set = new TreeSet<Integer>();//要升序排,所以TreeSet,存整数

            while(n-- != 0) {
                set.add(sc.nextInt());//set集合自然没有重复元素
            }

            Iterator<Integer> it = set.iterator();
            System.out.print(it.next());//it.next()返回迭代的下一个元素!!防止输出错误
            while(it.hasNext()) {
                System.out.print(" " + it.next());

            }
            System.out.println();
        }
        sc.close();
    }
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324851946&siteId=291194637