How Many Nines


How Many Nines

Time Limit:  1 Second       Memory Limit:  65536 KB

If we represent a date in the format YYYY-MM-DD (for example, 2017-04-09), do you know how many 9s will appear in all the dates between Y1-M1-D1 and Y2-M2-D2 (both inclusive)?

Note that you should take leap years into consideration. A leap year is a year which can be divided by 400 or can be divided by 4 but can't be divided by 100.

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow. For each test case:

The first and only line contains six integers Y1M1D1Y2M2D2, their meanings are described above.

It's guaranteed that Y1-M1-D1 is not larger than Y2-M2-D2. Both Y1-M1-D1 and Y2-M2-D2 are between 2000-01-01 and 9999-12-31, and both dates are valid.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case, you should output one line containing one integer, indicating the answer of this test case.

Sample Input

4
2017 04 09 2017 05 09
2100 02 01 2100 03 01
9996 02 01 9996 03 01
2000 01 01 9999 12 31

Sample Output

4
2
93
1763534

Hint

For the first test case, four 9s appear in all the dates between 2017-04-09 and 2017-05-09. They are: 2017-04-09 (one 9), 2017-04-19 (one 9), 2017-04-29 (one 9), and 2017-05-09 (one 9).

For the second test case, as year 2100 is not a leap year, only two 9s appear in all the dates between 2100-02-01 and 2100-03-01. They are: 2017-02-09 (one 9) and 2017-02-19 (one 9).

For the third test case, at least three 9s appear in each date between 9996-02-01 and 9996-03-01. Also, there are three additional nines, namely 9996-02-09 (one 9), 9996-02-19 (one 9) and 9996-02-29 (one 9). So the answer is 3 × 30 + 3 = 93.

【Link】

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5569

【题解】

啦啦啦博客督促我补题耶耶耶


nine[ ]记录2000-01-01到9999-12-31的每天累计的9的数量

【代码】

#include<bits/stdc++.h>
using namespace std;
int nine[10000][14][35];  
int month1[13]={0,31,29,31,30,31,30,31,31,30,31,30,31};  //闰年
int month2[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int f(int y)
{
    if(y%400==0||(y%4==0&&y%100!=0))
        return 1;
    return 0;
}
int cul(int n)
{
    int ans=0;
    while(n)
    {
        if((n%10)==9)
            ans++;
        n/=10;
    }
    return ans;
}
int fun()
{
    int y,yy,m,mm,d;
    for(y=2000;y<=9999;y++)
    {
        nine[y][0][0]+=nine[y-1][12][31];
        yy=cul(y);  
        if(f(y))
            for(m=1;m<=12;m++)
            {
                nine[y][m][0]+=nine[y][m-1][month1[m-1]];
                mm=cul(m);  
                for(d=1;d<=month1[m];d++)
                {
                    nine[y][m][d]=nine[y][m][d-1]+yy+mm;
                    if(d==9||d==19||d==29)
                        nine[y][m][d]++;
                }
            }
        else
            for(m=1;m<=12;m++)
            {
                nine[y][m][0]+=nine[y][m-1][month2[m-1]];
                mm=cul(m);
                for(d=1;d<=month2[m];d++)
                {
                    nine[y][m][d]=nine[y][m][d-1]+yy+mm;
                    if(d==9||d==19||d==29)
                        nine[y][m][d]++;

                }
            }
    }
}
int  main()
{
    fun();
    int n,y1,m1,d1,y2,m2,d2;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d%d%d%d%d",&y1,&m1,&d1,&y2,&m2,&d2);
        printf("%d\n",nine[y2][m2][d2]-nine[y1][m1][d1-1]);
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324644773&siteId=291194637