hdu1381Crazy Search hash map template title

Crazy Search

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3087    Accepted Submission(s): 1154


Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5. 
 

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
 

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Sample Input
 
  
13 4print
 

Sample Output
 
  
5
 

Recommend
The first hash table is a bit more complicated than the second
#include<stdio.h>
#include<string.h>
using namespace std;
#define SIZE 16000005
#define mod  16000005
using namespace std;
 
int n,nc;
char str[SIZE];
int hash[30];
bool vis[SIZE];

intmain()
{
	int T;
	scanf("%d",&T);
	for(int t=1;t<=T;t++)
	{
		scanf("%d%d",&n,&nc);
		scanf("%s",str+1);
		memset(hash,0,sizeof(hash));
		memset(vis,0,sizeof(vis));
		int len=(int)strlen(str+1);
		int val=0;
		for(int i=1;i<=len;i++)//Each different character corresponds to a different weight
		{
			if(!hash[str[i]-'a'])
			hash[str[i]-'a']=++val;
			if(val==nc)
			break;
		}
		int ans=0;
		for(int i=1;i<=len-n+1;i++)//enumerate substrings pay attention to the range of loop variables i and j
		{
			int sum=0;
			for(int j=i;j<=i+n-1;j++)
			sum=sum*nc+hash[str[j]-'a'];
			
			sum%=mod;
			if(!vis[sum])
			{
				force[i]=true;
				years++;
			}			
		}
		printf("%d\n",ans);
		if(t!=T)
		printf("\n");
	}
	return 0;
}

The second is to map with map
#include<iostream>
#include<string>
#include<map>
using namespace std;
intmain()
{
	int t,n,nc;
	cin>>t;
	while(t--)
	{
		string s;
		map<string,int> smap;//map mapping
		cin>>n>>nc>>s;
		int k=0;
		int len=s.length();
		for(int i=0;i<=len-n;i++)
		{
			string ss=s.substr(i,n);//Extract substring
			if(smap[ss]==0)
			{
				k++;
				smap[ss]=1;
			}
		}
		cout<<k<<endl;
		if(t>1)
		cout<<endl;
	}
	
	return 0;
}




Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324517760&siteId=291194637