HDU 1503-Advanced Fruits (Dynamic Programming, LCS)

Topic link:

http://acm.hdu.edu.cn/showproblem.php?pid=1503

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3622    Accepted Submission(s): 1872
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
   
   
apple peach ananas banana pear peach
 

Sample Output
  
   
   
appleach bananas pearch
 
//LCS
//求出最长公共子序列
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 1005
using namespace std;

int dp[maxn][maxn];
int mark[maxn][maxn];
int l1, l2;
char s1[maxn], s2[maxn];

//求出最长公共子序列,并利用mark数组来标记选了哪个字符串
void LCS()
{
	memset(dp, 0, sizeof(dp));
	memset(mark, 0, sizeof(mark));
	for(int i=1; i<=l1; i++)
        mark[i][0] = -1;
    for(int i=1; i<=l2; i++)
        mark[0][i] = 1;
	for(int i=1; i<=l1; i++)
		for(int j=1; j<=l2; j++)
		{
			if(s1[i-1]==s2[j-1])
			{
				dp[i][j] = dp[i-1][j-1] + 1;
				mark[i][j] = 0;
			}
			else
				if(dp[i-1][j]>dp[i][j-1])
				{
					dp[i][j] = dp[i-1][j];
					mark[i][j] = -1;
				}
			else
			{
				dp[i][j] = dp[i][j-1];
				mark[i][j] = 1;
			}
		}
}

//回朔输出
void print_LCS(int s, int t)
{
	if(!s && !t)
		return;
	if(mark[s][t]==0)
	{
		print_LCS(s-1, t-1);
		printf("%c", s1[s-1]);
	}
	else
		if(mark[s][t]==1)
		{
			print_LCS(s, t-1);
			printf("%c", s2[t-1]);
		}
	else
		{
			print_LCS(s-1, t);
			printf("%c", s1[s-1]);
		}
}
int main()
{
	while(cin>>s1>>s2)
	{
		l1 = strlen(s1);
		l2 = strlen(s2);
		LCS();
		print_LCS(l1, l2);
		printf("\n");
	}
	return 0;
}



Guess you like

Origin blog.csdn.net/qq_31281327/article/details/76358214